2

When double-clicking any video (I tried different formats) VLC just open and close again after around 14 seconds:

VLC not running

It works fine if I:

  • Open VLC from terminal or any other way and then open the same file.
  • killall nautilus, run nautilus and double-clic the file (that surprise me).
  • Use Nemo, Double-commander or other file manager and double-clic the file.

Last think make me think is a nautilus bug, but doesn't happen with any other program.

I tried:

  • Bizarre things like tring to fetch stdout/stderr with strace -p`pgrep -l '^vlc$' | col1 | head -1` -s9999 -e write with watch. I couldn't do it.
  • On Exec parameter of /usr/share/applications/vlc.desktop I have /usr/bin/vlc --started-from-file %U. Without luck, I tried changing to:
    • /usr/bin/vlc
    • xterm -e "vlc"
    • gnome-terminal -e "vlc". In this last case before previous behavior I get this window: enter image description here

File format is correctly associated with VLC. If I associate it with other program everything goes fine.

I believe this is a different situation than this one. I already read this, this and this.

Maybe a related useful question could be: How exactly Nautilus run associated program of double-clicked file?

Update 2018-02-12

This happened with Unity, on Ubuntu 16.04. Now with VLC 2.2.2-0-g6259d80 and GNOME nautilus 3.14.3 I don't have this problem anymore. So probably it was a bug on nautilus (since is the same version of VLC).

  • have you managed to fix this? – Govi S May 31 at 17:18
  • @GovindaSakhare Please see the update at the end. I've just make it more clear. I don't have this issue anymore. – Pablo Bianchi May 31 at 19:47
1

Open the terminal:

sudo nano /usr/share/applications/vlc.desktop

After Exec= add:

/usr/bin/vlc --started-from-file %U

If this doesn't work, try just with /usr/bin/vlc. Last resort you could use the following line:

xterm -e "vlc"

But I assume you want to avoid terminal dependency.

| improve this answer | |
  • Doesn't work. file already have "--star..". Both other options didn't work. gnome-open filename from terminal also works fine. Maybe is more a nautilus problem. – Pablo Bianchi Apr 8 '17 at 17:35
  • 1
    Exec=xterm -e "vlc" or Exec=gnome-terminal -e "vlc"in /usr/share/applications/vlc.desktop should work regardless. But yeah, seems to be a bug – user633551 Apr 8 '17 at 17:47
1

I had a very similar issue - doubleclicking a file did not seem to do anything but when running VLC from command line I was able to play videos. The VLC GUI was missing though.

Because Pablo Bianchi suggested doing killall nautilus, I ran nautilus from command line. That showed me that when I doubleclicked a video, VLC displayed errors I could not see without the command line. I then googled them and stumbled upon this thread.

For me, installing QT4 fixed the problem. Apparently it was an issue with the VLC GUI, not Nautilus.

| improve this answer | |
  • Please add the details of how to install Qt 4. – Chai T. Rex Feb 11 '18 at 1:41
  • I'm on Antergos, so I just did pacman -S qt4. Pretty sure on Ubuntu you can also apt install qt4. Apparently qt5 was installed but VLC is not compatible. – Konzertheld Feb 11 '18 at 12:57
  • There's no qt4 package. – Chai T. Rex Feb 12 '18 at 4:23
  • I updated the question. I don't have any qt4-* package installed. – Pablo Bianchi Feb 12 '18 at 4:35
  • @ChaiT.Rex There are several qt4 packages in Ubuntu. packages.ubuntu.com/… – Konzertheld Feb 12 '18 at 15:49
0

Had same problem. This worked for me:

  1. Open VLC > Tools > Preferences > "Show all" settings
  2. Scroll to Interface> Main Interface
  3. Uncheck qt4 interface
  4. Save

screenshot

All worked OK then.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.