2

I made a clean install on my Sony Vaio laptop, of Ubuntu 11.10 and when the installation was ready, it prompted to remove the USB I was installing the distro from, and press enter to reboot. After this reboot the first thing I got was the following error:

error: couldn't read file
error: you need to load the kernel first

Press any key to continue..

After that it throws me back to the Grub select screen:

Ubuntu, with linux 3.0.0-14-generic-pae
recovery mode
previous Linux versions (none since I made a clean install)
memory test

If I choose the first option it shows only a black screen and never loads anything. If I reboot the same thing happens.

Could I repair this using boot-repair? Is there any other way?

Note: I know nothing about Linux code so I am a total noob on this one

Update: boot-repair did not help

Grub.cfg here: http://pastebin.com/GKLuDuhM

Boot Info Script: http://pastebin.com/indARkKJ

  • Hi - please look at the Q&A and pastebin the output from the script that is suggested to be run. askubuntu.com/questions/90045/… – fossfreedom Dec 24 '11 at 12:56
  • Thanks for your reply. I have pasted the info here: pastebin.com/indARkKJ – Angelos318 Dec 24 '11 at 13:16
  • Some possible solutions have been posted earlier in this similar question. These might help you. – Exeleration-G Dec 24 '11 at 13:23
  • I have tried the boot-repair, mind you, I dont understand much of the other stuff posted there... :( – Angelos318 Dec 24 '11 at 13:30
  • you have "nomodeset" in your recovery boot options but "acpi=off" in the normal boot options. Why? If you select "recovery mode" what happens? If you press "e" on the first option and change "nomodeset" for "acpi=off" (or just remove "nomodeset") followed by CTRL+X to boot, what happens? – fossfreedom Dec 24 '11 at 13:57
0

Try to check your disk drive, it means that GRUB really can't read the file /boot/vmlinuz.... You can check the file by trying to copy it or the disk with badblocks command as suggested on http://www.linux.org.ru/forum/linux-hardware/7228767 (in Russian).

Not the answer you're looking for? Browse other questions tagged or ask your own question.