8

On my system, the “门” character looks super weird. I expect it to look like this:

门 (mén) character that doesn't look weird

But instead it looks like this:

门 (mén) character that looks weird

I'm running Xubuntu 16.10 with the Chinese Language pack but not the Japanese language pack installed. I don't know what font it's displayed in but the second screenshot is from my system default.

6
  • 1
    You are using the noto for Japanese font , select other font begin with noto, see which one is for Chinese.
    – wolfrevo
    Mar 22, 2017 at 4:59
  • @user-487 how do I move this question?
    – ioistired
    Mar 23, 2017 at 16:16
  • Can I migrate a question myself?,,,,,, move the question
    – user-487
    Mar 24, 2017 at 4:21
  • @user-487 I can't ask that it be moved other than to chinese.meta.stackexchange.com :\ so I'll just flag it normally
    – ioistired
    Mar 27, 2017 at 2:30
  • I think the easiest way is that you ask again on that site.
    – user-487
    Mar 27, 2017 at 7:09

1 Answer 1

9

You can use fc-list :lang=zh-cn to list all fonts you install. I believe it is the bug in Ubuntu. Your system may use the wrong font to show simplified Chinese.

Take a look at your /etc/fonts/conf.d/64-language-selector-prefer.conf file, you may find the following:

<alias>
      <family>sans-serif</family>
      <prefer>
         <family>Noto Sans CJK JP</family>
         <family>Noto Sans CJK SC</family>
         <family>Noto Sans CJK TC</family>
      </prefer>
   </alias>
   <alias>
      <family>monospace</family>
      <prefer>
         <family>Noto Sans Mono CJK JP</family>
         <family>Noto Sans Mono CJK SC</family>
         <family>Noto Sans Mono CJK TC</family>
      </prefer>
   </alias>

What you need to do is move JP item to last. Highly recommand you to install Google Noto.

You can found more here.

4
  • I got this problem on iOS as well, after I changed my phone's language to Japanese. Is there a fix for iOS as well?
    – Sweeper
    Mar 25, 2017 at 12:05
  • @Sweeper Japanese font show this font error. I think if you change your system's language to Chinese can solve this problem. But if you prefer Japanese, I don't think iOS has an option to choose prefer font.
    – einverne
    Mar 28, 2017 at 3:06
  • Thanks for the solution. I never would have found that forum post! This is interesting to me though, seems like a Unicode problem. Almost as if these two characters should not be "unified" under CJK…
    – ioistired
    Jun 14, 2017 at 21:59
  • 2
    For the future reader: I had this problem in Linux Mint, where the file /etc/fonts/conf.d/64-language-selector-prefer.conf does not exist. I found a solution by creating the file ~/.fonts.conf (ref.), then following the instructions in this answer. Jan 25, 2018 at 5:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.