I am trying to run Citrix receiver on the Xenial version of Ubuntu, but I am getting this error below


Cannot connect to " - Remote Desktop Connection"

Unknown error 1000119. Verify your connection settings and try again.

What should I do?

7 Answers 7


Remove cacerts and link to /etc/ssl/certs by the following commands

cd /opt/Citrix/ICAClient/keystore/
sudo rm -rf cacerts
sudo ln -s /etc/ssl/certs cacerts

Source: comment by bdetweiler which helped me.

  • 22
    This should be the accepted answer Mar 28, 2018 at 0:27
  • 4
    you need to sudo before rm and ln but yes perfect
    – xam
    May 15, 2018 at 14:28
  • 4
    This helped me, for the first time ever, get Citrix Receiver working in a Linux distribution! Thanks!
    – Wes
    May 18, 2018 at 16:27
  • 2
    I have tried the above solution. But still the same error. Can somebody pls help May 26, 2018 at 3:48
  • 8
    Suggest sudo mv cacerts cacerts.OLD rather than just a straight up purge.
    – Corey S.
    Jul 6, 2018 at 18:34

I got it. Linking the system's certificates to the ICA's also works:

sudo ln -s /etc/ssl/certs/* /opt/Citrix/ICAClient/keystore/cacerts

with ignoring the warnings regarding duplicates.

  • 1
    It's worked for me. Mar 25, 2020 at 9:07

I had the equivalent problem. The best solution I was able to find at the moment in Xenial was to downgrade to the 13.2 x64 version of Citrix Receiver and be sure to follow the standard procedures with respect to linking certificates, etc.


I solved this by getting the root cert. In my case it was Verisign, so I downloaded the root 10 cert from https://www.symantec.com/theme/roots

Get root 10. It'll be a file called verisign-universal-root-certification-authority-en.pem sudo copy it into /opt/Citrix/ICAClient/keystore/cacerts

It worked straight after.

  • 7
    This worked for me: cd /opt/Citrix/ICAClient/keystore/; rm -rf cacerts; ln -s /etc/ssl/certs cacerts;
    – bdetweiler
    Mar 20, 2018 at 23:07

I had the same problem. For me the solution was to put in, 

as DNS in the network manager

  • Upvoting as this error message was a DNS issue for me too (the certificates above didn't solve it).
    – moo
    Apr 7, 2020 at 8:34

I solved this error by use the following Steps

cd /opt/Citrix/ICAClient/keystore/cacerts/
wget https://dl.cacerts.digicert.com/DigiCertHighAssuranceEVRootCA.crt

curl https://support.comodo.com/index.php?/Knowledgebase/Article/GetAttachment/969/821026 > comodorsacertificationauthority.crt

I get solution from: https://stackoverflow.com/questions/53062679/cannot-connect-to-0-0-0-2-published-app-name-in-citrix-receiver-ica-client


I was not able to permanently solve the issue with the solutions here. I found a suggestion here which solved my problem.

If you don't know the URL the app asks you for; it is the URL of your organisation's "Citrix storefront" (where you download your .ica files)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .