2

Problem statement: I have an external USB drive that won't mount.

Context:

  1. I neither have nor desire access to MS Windows.
  2. See 1.
  3. External USB drive is NTFS formated.
  4. There is no RAID.
  5. I've been a Linux user for many years and am not afraid of the CLI.
  6. I would rather not wipe it and start from scratch but it isn't critical if I can't avoid it.

Error looks like:

Error mounting /dev/sdc1 at /media/dude/External HD: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sdc1" "/media/dude/External HD"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdc1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.
 (udisks-error-quark, 0)
2
8

You can try to use ntfsfix in order to repair the NTFS volume. This is a 'solution' in that it can fix simple errors such as the MFT and MFTMirror not matching up, and some minor filesystem incongruities. Note that if nftsfix doesn't fix the drive up so it's usable, you'll need to use the tried-and-true "Use a Windows system to repair NTFS" solution.

sudo ntfsfix /dev/sdXY (where X and Y are the letter of the drive's device and Y is the partition number, you can get this data off of sudo fdisk -l but it looks to me like this should be /dev/sdc1 for your specific case) should then work.

Note that the still tried-and-true "complete" solution for fixing NTFS problems is a Windows system or a Windows boot disk (or even a Windows VM that you pass the external USB drive through to), and using chkdisk from the Windows system.

5
  • The only reason I bother with NTFS is so that it can be read from Windows but I actually can't stand Windows. ;-) – user447607 Apr 7 '17 at 19:31
  • @user447607 Well, if nftsfix doesn't fix the problem, since you'll need a Windows system somewhere (VM or a boot disk to boot to temporarily) to fix the NTFS if ntfsfix doesnt work. (ANd if WIndows chkdisk also fails to fix it, we can start to assume something is bad with the drive) – Thomas Ward Apr 7 '17 at 19:31
  • Not irrelevant, just means I DO have to wipe it. Anyway ntfsfix seems to have done the trick. – user447607 Apr 7 '17 at 19:44
  • @user447607 Glad to hear it! Please feel free to upvote my answer, and mark it as accepted with the checkmark at the left underneath the up/down vote buttons :) – Thomas Ward Apr 7 '17 at 19:44
  • I use Windows when I'm required to by other people but considering the historical business practices of that particular company, I consider it an ethical compromise and prefer not to contribute to it or it's ecosystem when ever possible. Especially when it's a personal endeavor, not a professional one. Also, if it's something we need to do, it should be doable on Linux as a general rule for our favorite OS. :-) – user447607 Apr 8 '17 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.