0

Can't connect to MySQL server on '127.0.0.1' (111)

I have install mysql Workbench using ubuntu software center, now i want to create a connection but facing this problem.

1

Ok, This means that you need to install MySQL first, or connect to a machine with MySQL installed. Check this URL on how to do so on Ubuntu https://www.linode.com/docs/databases/mysql/install-mysql-on-ubuntu-14-04

1

I faced this problem once. The issue was that the allowed host for root was localhost. The host was not unable to map localhost to 127.0.0.1. In your my.cnf file, set the bind address as follows:

bind-address = 127.0.0.1

To allow all IPs use %.

Restart the server and then check.

1

same issue i faced with mysql workbench 6.3.8 build 1228 CE (64-bits) community with kubuntu 18.04 version.

i set connection method standard tcp/ip over ssh and when i try to connect to remote server it asks for ssh password and after successful ssh tunnel it asks for remote mysql password ( which was expected as i did not store passwords in keychain -- option available there in connection window ) and when i entered it i got same above error.

after checking at server mysql log i found this line: Access denied for user 'root'@'localhost' (using password: NO)

but i already entered the password while workbench asks me.

finally i try edit connection and store mysql password there in keychain option and it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.