As the title says: when I click Shutdown from the menu it logs off. When I click shutdown from the log-in menu it does nothing. I'm using a fresh install of Ubuntu 11.10. I can force it to shutdown by the command below, but I don't want to keep typing that whenever I want to shutdown my laptop.

sudo shutdown -h now

So it's probably processes which arn't closing. I'm a novice linux user, so I have no idea how to rule out the software causing this. I think it's either Gwibber/Empathy, perhaps Mozilla Thunderbird, because this is happening since I started using this.

So a few questions:

  1. How do I rule out what software is causing this?
  2. How do I stop it from not closing on shutdown?
  3. If 1. and 2. don't work is it possible to add top command to the shutdown process?

Edit: Rourke here. Somehow I cannot accept the below comment from mech-e as the solution. Thank you this was indeed the answer I was looking for!


Is your account set to autologin and is your home folder encrypted? Had same problem and fixed it by turning 'autologin' for user off. Need to do sudo reboot or shutdown -h now from terminal, then either use GUI via User Account settings and turn off autologin or follow these steps from https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/838792 :

raggar (mbaart) wrote on 2011-11-04: #24

I found a possible solution to this bug. It has something to do with the auto login >function in the user management from Unity. When activated it cannot shutdown anymore. >Also disable the auto login is not possible anymore.

What I did: gksudo gedit /etc/lightdm/lightdm.conf

remove the line: autologin-user= YOUR USERNAME

Restart your computer with: sudo shutdown -h now

After that I had a system that worked normally again.

  • this solution did not solve my problem. – ultrajohn Jan 25 '12 at 4:16
  • @ultrajohn Since it did solve the OP's problem and didn't solve yours, your probably probably differs from the OP's in some important (but possibly subtle) way. I recommend posting a new question about your problem. You can include a link to this question in your new question. – Eliah Kagan Jun 11 '12 at 9:31

Had the same issue and tracked it down to having another account/profile logged in at the same time.

Logged into Account A Switched to Account B (testing a new user) Forgot about A, User B couldn't shutdown and would drop back to the login screen.

Fix : Logout of Account A, B can now shutdown.


I had this problem too and found a solution here:


It was a simple fix and worked for me!

  • 3
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference – fossfreedom Apr 22 '12 at 16:33

I had this problem and discovered it was from having a running shutdown command waiting for a particular time.


I was facing the same problem when I updated ubuntu from 14.10 to 15.04. So, for this I searched online and found many things but not real answer. But by now I know that there is an app named Plank does not let that shutdown happen. So, we have 3 option,

1. We can remove it and replace it with Docky .

2. We can modify its startup and shutdown scrips.

3. Or just close it manually and you are good to go.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.