2

I'm trying to run sudo mokutil --disable-validation and sudo mokutil --import MOK.der But, I get this message in Command line:

EFI variables are not supported on this system

lsblk output:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 232.9G  0 disk 
├─sda1   8:1    0   4.7G  0 part [SWAP]
├─sda2   8:2    0     1K  0 part 
├─sda5   8:5    0  82.9G  0 part /media/ali/8593EB75DEE9C7C1
└─sda6   8:6    0 145.4G  0 part /
sdb      8:16   0 465.8G  0 disk 
└─sdb1   8:17   0 465.8G  0 part /media/ali/Local Disk

What is that?

How can the problem be solved?

Ubuntu version is 16.04 LTS.

7
  • you have installed ubuntu in UEFI, right? Apr 7 '17 at 4:55
  • @SumeetDeshmukh I do not know about it!
    – Ali Hesari
    Apr 7 '17 at 4:58
  • can you quickly run lsblk and update the question with resulting out put. Apr 7 '17 at 4:59
  • @SumeetDeshmukh Updated.
    – Ali Hesari
    Apr 7 '17 at 5:02
  • there is a 1k partition i'm not sure if it's EFI, maybe other some other user will be able to help Apr 7 '17 at 5:04
2

I had the same problem when trying to compile a kernel module in a Virtualbox guest machine (Ubuntu 16.04). In this case, the CONFIG_MODULE_SIG kernel config option requires kernel modules to be signed. However, UEFI and, thus, Secure Boot are not available so you can't actually sign the module. And as you noticed, disabling the validation doesn't work either.

In this case, the only solution that worked for me was to recompile the kernel following the instructions at Ubuntu Wiki. These instructions worked for me as they were with the only exception that I also had to install libncurses5 and libncurses5-dev via apt.

When changing the configuration options with fakeroot debian/rules editconfigs, disable the Module signature verification option in the Enable Loadable Module Support section. I did that for every single arch/flavor, which might or might not be necessary.

This approach worked for me, and if you don't screw up too much (as I did...), it should be done within 30 minutes (plus compile time, which depends heavily on your system). Note, however, that compiling the kernel took around 15 GB of disk space for me. Also, make sure to hold your kernel packages later so you don't accidentally upgrade your kernel (you will have to repeat the procedure for each new kernel version).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.