4

I can not install the TP-LINK WN722N V2, which includes a 8188 EUS chip. Then I tried to install the backports v4.4.2,but do not want to recognize either.

The TP-Link driver installation errors thrown out:

man@kman-livve:~$ cd '/home/kman/Documents/Tplink 722 N V2/rtl8188EUS_linux_v4.3.0.8_13968.20150417'
kman@kman-livve:~/Documents/Tplink ...$ sudo make

"******************************************"
"NO SKRC,we will use default KSRC"
"******************************************"
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.10.0-15-generic/build M=/home/kman/Documents/Tplink 722 N V2/rtl8188EUS_linux_v4.3.0.8_13968.20150417  modules
make[1]: Entering directory '/usr/src/linux-headers-4.10.0-15-generic'
arch/x86/Makefile:140: CONFIG_X86_X32 enabled but no binutils support
make[1]: *** No rule to make target '722'.  Stop.
make[1]: Leaving directory '/usr/src/linux-headers-4.10.0-15-generic'
Makefile:1367: recipe for target 'modules' failed

A method to know him, I do not know about. Thanks

Model:TL-WN722N(EU)_V2_161112_Linux.zip Chipset:rtl8188EUS_linux_v4.3.0.8_13

http://www.tp-link.com/en/download/TL-WN722N.html#Driver

  • 1
    Welcome to AskUbuntu! I'm sorry but your question is completely unclear please review askubuntu.com/help/how-to-ask and then edit your post so that we can understand. You may find this post useful. – Elder Geek Apr 6 '17 at 13:13
  • RTL8188EUS is supported - just works - in 16.04. Use an alternative connection and make sure the OS is fully updated. – user589808 Apr 6 '17 at 14:03
  • Please edit the question to include results from terminal for rfkill list all; lsusb – Jeremy31 Apr 6 '17 at 22:22
  • lsusb [s11.postimg.org/651nvx24z/… Bus 004 Device 003: ID 2357:010c – Klpo Apr 7 '17 at 11:45
  • I am having the a similar problem. I am also trying to install a TL-WN722n V2 (EU) wireless adapter in 16.04 LTS. I downloaded the file and the install process put out the following: Install Error 1 Also the output of lsusb is: ID 2357:010c and lsusb -t gives no further driver info. I have yet to be able to plug the adapter in and get the green light to turn on – Matthew Apr 11 '17 at 15:19
5

for version 2 the driver provided on official website don't work it has chip-set of RTL8188 so install "lwfinger" drivers

step:1 make a temporary directory

$ mkdir tmp

step:2 move to temporary directory

$ cd tmp

step:3 clone driver repository

$ git clone https://github.com/lwfinger/rtl8188eu.git

step:4 change directory of cloned repo !

$ cd rtl8188eu

step:5 make the driver for your system (Note: you should have kernal headers to make, google it !)

$ make all

step:6 after successful make

$ sudo make install

step:7 reboot your system

$ sudo reboot

after rebooting you will see the notification light turning on. have a nice day :)

edit: 10/03/2018

As @BradHein suggested step 7 isn't required , just plug out and plug in the adapter again!

  • This is the best answer however as a die hard Linux fan I try to avoid reboots at all cost. In this case, simply unplugging and plugging in the USB Wi-Fi device is sufficient :) – Brad Hein Dec 20 '17 at 13:59
4

Your folder name has spaces in it that make it impossible to compile with make. Remove the spaces and it should compile. Your folder is named /home/kman/Documents/Tplink 722 N V2/rtl8188EUS_linux_v4.3.0.8_13968.20150417 and that is why you see the error ** No rule to make target '722'. as make expects the first thing after the space to be something defined in the Makefile such as modules or install

0

Regarding to lwfinger driver I had a problem to use it as access point. So I have ported original TP-Link driver to work with kernel 4.9.

I have tested it on kali but I assume you will have no problems to use it with ubuntu: https://github.com/mfruba/kernel/tree/master/drivers/TL-WN722N_v2.0-Ralink

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.