0

so, ive been having troubles with some games regarding the proper divers i should use.

First: ive tried selecting the nvidia driver in the additional drivers tab, yet this is the output of lspci -k | grep -EA2 'VGA|3D':

00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated Graphics (rev 06)
    Subsystem: Lenovo Skylake Integrated Graphics
    Kernel driver in use: i915_bpo
--
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
    Subsystem: Lenovo GM107M [GeForce GTX 960M]
    Kernel driver in use: nouveau

wich suggest to me the nouveau driver is in use instead of the NVIDIA binary driver - version 375.39 van nvidia-375 (niet vrij, getest) that is selected in the drivers tab.

also, i cant open the prime profiles tab in the nvidia X server settings screen, but using 'sudo prime-select nvidia' as suggested by https://www.linuxbabe.com/desktop-linux/switch-intel-nvidia-graphics-card-ubuntu seemed to bypass this problem.

after rebooting, Ubuntu noted "the system is running in low graphics mode", wich i fixed with How to fix "The system is running in low-graphics mode" error?.

Wich made me start all over again. repeating gave same issues. I have no idea why this low graphics happened, or why nouveau is still beeing mentioned in my output. but my nvidia is still not beeing properly used.

Sorry for my bad english, it's my third language.

  • Disable Secure Boot in BIOS. – Pilot6 Apr 6 '17 at 10:48
  • secure boot was disabled already – bartolo 05 Apr 6 '17 at 11:00
  • @Pilot6 any other things i might have to do? – bartolo 05 Apr 6 '17 at 11:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.