Bought a fanless computer from quietpc. Some hard-ware info:

  • Machine name: Sentinel Fanless Mini PC
  • Motherboard: Gigabyte GA-H270N-WIFI Mini-ITX Motherboard
  • Processor: Intel 6th Gen Pentium G4520 47W HD 530 3MB Dual Core CPU
  • RAM: Corsair DDR4 Vengeance LPX 8GB (2x4GB) 2400MHz Memory Kit
  • Storage: 256GB Samsung PM961 Polaris NVMe M.2 SSD (2800/1100)

Installed ubuntu 16.04 from a ubuntu-16.04.2-desktop-amd64 iso installed on a usb drive.

While installing, my internet connection, which always looked a bit shakey, broke, and I don't think the installer managed to fetch all the desired external packages. It went ahead and installed anyway.

The new set-up booted fine (in fact, at this point everything seemed to be going brilliantly).

But then I hit a HUGE problem. The Internet-connection in my new machine was and is very slow and frail - virtually useless.

I have not yet been able to update my package-lists, but I seem to have around 350MB of updates to download - impossible with my machine in its present state.

Preliminary research suggested that my problem might be similar to the problem described here:

Wifi not working (Intel) on HP Spectre x360 13

[But could it also be a boot-problem - I have an M.2 drive?]

The o/p of lspci -vvnn | grep Network:

05:00.0 Network controller [0280]: Intel Corporation Device [8086:24fd] (rev 78)

The o/p of lspci -vvnn | grep kernel:

Kernel driver in use: igb
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

Following the advice given in the link above (questions 858546), I downloaded (to another machine), physically transferred, and installed:


the 1.162-file was not available

o/p of uname -a

Linux azed-qpc 4.8.14-040814-generic #201612101431 SMP Sat Dec 10 19:33:51 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

This desperate step didn't work.

closed as off-topic by Pilot6, karel, Eric Carvalho, David Foerster, Anwar Apr 13 '17 at 18:29

  • This question does not appear to be about Ubuntu within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    I'm voting to close this question as off-topic because problems with unsupported kernels are off-topic. – Pilot6 Apr 6 '17 at 9:17
  • Hey, stop choking that toad, guys. Let's have some creative suggestions, here. I've heard (="read it on the Internet") that U16.10 supports my wireless card. Is this true? If so, would dual booting U16.10 and then chrooting into the Ubuntu 16.04-system do any good? Would that work? Still desperate. – StephenH Apr 6 '17 at 15:33
  • Please switch to a kernel provided by Canonical for your Ubuntu distribution and see if the issue persists. You're welcome to ask how to do that if you don't know. – David Foerster Apr 7 '17 at 21:33

In the interests of closure...

The answer turned out to be embarrassingly simple. I broke the seal on the box marked: "Don't throw this box away; it contains things you might need if you upgrade your system" that came with my kit, and plugged the small aerial contained therein into my computer.

Result: instant full-strength Internet.

A subsequent re-install confirmed my suspicion that my Ubuntu 16.04 system, supplied with an aerial, would have worked "out of the box". My software modification efforts added nothing.

Spot the noob, eh?


Internet research can give you a false picture about the frailty of Ubuntu software

Ask Ubuntu respondees: don't feel inhibited about offering-up dismissive "Have you tried plugging it in?"-type solutions - they sometimes work.

  • Great answer! I only wish I could give you a thousand likes. – StephenH Apr 10 '17 at 21:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.