0

Can't install Lubuntu

the 'grub-efi-amd64-signed' package failed to install into / target/. without the grub bootloader the installed system will not boot

On a Macbook Air late 2010?

marked as duplicate by karel, Thomas, Eric Carvalho, user535733, David Foerster Sep 11 '18 at 17:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

If the system boots OS X, the simplest solution may be to boot it and install my rEFInd boot manager. With rEFInd installed, you won't need GRUB; and because of the history of Mac booting and higher expectations of GUI tools, many Mac users prefer using rEFInd to GRUB anyway. If you're single-booting Ubuntu, you could do something similar by using a rEFInd USB drive or CD-R image to boot to Ubuntu once, then install the PPA or Debian package.

That said, I've seen a recent uptick in reports like yours. There are also quite a few bug reports about this issue on Launchpad, but most of them have been marked as "invalid" because they're caused by things like damaged ESPs or other configuration problems. There may be an underlying bug that's at the root of the recent uptick in problems, though, and checking more Launchpad bugs than I did (I reviewed just the first few in the Google search) might uncover the root cause.

If you really want to uncover the root cause of your problem, or if you can't get rEFInd to install, then please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration.

1

I had the same issue on my 2015 macbook air with High Sierra installed, trying to install via USB disk made with UNetbootin. Initially tried disabling csrutils in Mac OS recovery mode, and also made sure to check "Download updates while installing" during the Ubuntu installation (I had to click "back" after installing the wifi drivers on that screen in order to do this, since the two checkboxes are on the same screen in the ubuntu installation wizard). I also tried installing with and without REfind.

With the variations above, I tried four times and every time I got the dreaded "grub failed to install to target" message, and the installation crashed.

However, on the fifth try, I did one thing different: I made a swap partition during the partitioning part of the ubuntu installation wizard (previously, I had chosen to continue without a swap partition, and just ignored the warning message I got. As for the rest, I had csrutils back on because I didn't think that caused any troubles, but still made sure to check "download updates while installing". This time it worked, and there was no grub failure message. For the rest of the installation, I followed the instructions here for installing without REfind.

By the way, if you install without REfind according to the instructions linked, ubuntu will be set to the default boot OS. To boot into Mac OS, you would need to hold option after powering on/restarting, then select it. To change the order, you cannot use the Startup Disk system preferences, since you won't see Ubuntu as an item. However, there's a very easy trick to set the default: hold option after boot, then when you get to the screen with the Mac Boot where you can select either Mac HD or EFI Boot (ubuntu), hold CTRL and the up arrow below Mac HD will turn into a circular arrow. Click on that, and Mac will be set as the default!

Not the answer you're looking for? Browse other questions tagged or ask your own question.