0

I have installed Plank program on my Ubuntu Mate 16.04. Plank logo

But after first run it always run on system startup. I don't want to uninstall it, but I want to disable startup run. And there is no option on Ubuntu Startup Applications that I have seen. Can anybody explain, how to disable this application on startup?

  • There are two ways that can be done 1) from the application itself, 2) using systemd command. – George Udosen Apr 6 '17 at 7:44
  • Plank is installed by default on Ubuntu Mate, so when you say you installed I wonder. And please to stop it launching at startup, right click on the plank image and click quit. That worked for me... – George Udosen Apr 6 '17 at 8:36
  • @George, I tried do this and it work for me only for system session. After rebootin PC it appears again. And at application has no option to disable autostart – Oleg Apr 7 '17 at 6:41
0

In Startup Applications, click on the application you don't want to be open at the startup then click on remove button on the right. This doesn't unistall the app, only disable the application opening on startup. In alternative you may uncheck the chekbox on the left of the application name, it works too and you can reactivate the application at startup whenever you want easily.

Edit: if Plank doesent appear in startup application try:

 cd /etc/xdg/autostart/
 sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

It should show all deamons at startup, also the system one.

Edit2: with MATE Tweak go to interface->pannels and in the first select you should have selected Cupertino that has plank by default, now select MATE and plank should disappear

image

  • the problem that I have no option in Startup Applications list for Plank (I described this in question part). So I can't do this – Oleg Apr 7 '17 at 6:40
  • so you have not plank in the startup application list? Have you try to do : cd /etc/xdg/autostart/ and sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop thise way you should see all startup deamons... – Web Weavers Apr 7 '17 at 11:41
  • yea, I tried. Still no Plank option – Oleg Apr 7 '17 at 14:48
  • hav you try with MATE Tweak? – Web Weavers Apr 7 '17 at 20:30
  • I checked MATE Tweak, and it has no option. Or you mean something else? – Oleg Apr 10 '17 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.