I am running Ubuntu 11.10, and finally have figured out how to get my Broadcom BCM4306 wireless working. Unfortunately, I still have to enter the following commands "sudo modprobe -r b43 ssb" and "sudo modprobe b43" then enable networking and enable wireless every time after I reboot. Does anyone know how to make this process happen automatically?

Thanks for your help!


I do not know about that wireless device in special, but I do know something about modules

Concerning the modules, the commands you posted seem a bit confusing, as they first remove the module "b43" and then load it again:

sudo modprobe -r b43 ssb
#this removes (-r) the modules "b43" and "ssb" if they are already loaded (see *man modprobe*)

sudo modprobe b43
#this loads the module "b43"

To load a module at boot time, add the module-name to the end of the file /etc/modules (you can edit the file executing sudo gedit /etc/modules, for more info see man modules and man modprobe)

To explicitly prevent loading a module at boot time, you can blacklist it, by adding the module-name to the end of the file /etc/modprobe.d/blacklist.conf

So maybe in your case, it could be enough to add "ssb" into /etc/modprobe.d/blacklist.conf

Try it out and share with us :)

| improve this answer | |

Under 12.04 you just need to comment out blacklist bcm43xx in /etc/modprobe.d/blacklist.conf.

To do that, run this command in the Terminal:

gksu gedit /etc/modprobe.d/blacklist.conf

This will open the file in a graphical text editor. In the editor, find the blacklist bcm43xx line and put a # character at the beginning of it. Save the file and quit the text editor.

| improve this answer | |

Instead of putting sudo modprobe b43 in the /etc/modules just put b43.

I also commented out the b43 line in /etc/modprobe.d/blacklist.conf.

This worked for me.

| improve this answer | |

Once you get your modules straightened out (+1 to @zipzap for mentioning /etc/modprobe.d/blacklist.conf), make sure that the interface is marked connect automatically.

If You're using Network Manager, Edit Connetcions->"Wireless Tab->Select Connection->Edit and make sure "Connect automatically" is checked. See this answer for an image.

If you're not using Network Manager, add the name of your interface to the "auto lo" line, using sudoedit /etc/network/interfaces. Note: Be careful to not disrupt the "auto lo" line, or you will be very unhappy.

| improve this answer | |

I was facing the same issue. I wasn't able to edit the blacklist.conf file using gksu as it wasn't opening the file in any editor.

If I just open blacklist.conf by double clicking it used to open in read only mode.

So, the way I got it working is, from terminal I ran this query

sudo gedit /etc/modprobe.d/blacklist.conf

and added # before blacklist bcm43.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.