1

Earlier today a friend was going through my command prompt to see if I had certain things installed. He ran >$ sudo apt-get dist-upgrade , and cancelled ctrl^C it after ~30 minutes because it was taking too long

When I get home and turn on my laptop, the regular background doesn't load, the mouse won't move, and it disconnects from the internet. When I log on, the screen freezes, displays "A system error has occurred", and returns returns to login.

I've tried following the suggestions in this page but none of them have worked; Ubuntu gets stuck in a login loop

I cannot run any sudo apt-get commands because I cannot connect to the internet

As per that page's suggestion, I looked into .xsession-errors, and it appears that a whole whack of processes are killed by a TERM signal; indicator-sound, unity-settings-daemon, logrotate, indicator-bluetooth, indicator-power, datetime, session, and several others. (I would upload a photo but it's >2mgBs) What could be causing all these term signals??

One of the final suggestions on the page is to "re-install ubuntu". My main goal is to not lose any of my files, so if I do have to re-install ubuntu, how can i safely do it?

I know this is a big question but i also haven't slept in a couple days so Imm just trying to get some suggestions in total for the morning. In the worst case I'll bring it to someone who knows what they're doing. Thank you

0

Try this: At the login screen press ctrl - alt - F2. This will get you to a console interface. Login and try to continue the install with:

sudo apt-get install -f
  • Thank Carl, this definitely helped since I can now login. Xsession-errors no longer displays those messages anymore either. However, I cannot move the curser via by touchpad or using a mouse. I also cannot connect to the internet; it says internet is enabled but no connections are showing up (there should be several since im in an apartment buildin). Any idea what to try next? How can i fix the internet issue? edit: I should add that sudo >$ apt-get install -f ran for a while but returned with an error, E: Subprocess /user/bin/dpgk returned with an error code. – JontheK Apr 6 '17 at 16:42
  • Can you connect via cable? – Carl Apr 7 '17 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.