UPDATE: This appears to be an issue with Unity, as GNOME works.

I recently made the following changes which fix the palm detection for the touchpad on my Dell XPS 13. But, when I did so, it now prevents tap-clicking on menu items in applications (the window manager). I can tap-click on anything else though, and press-click works on the window manager menus though. If I remove my changes, tap-clicking works again on the window manager.

Anyone have experience with this?

Here are the changes I've performed. Running Ubuntu 16.04.

  1. Install xserver-xorg-input-libinput.

  2. Create /usr/share/X11/xorg.conf.d/90-libinput.conf containing:

    Section "InputClass"

           Identifier "libinput touchpad catchall"

           MatchIsTouchpad "on"

           MatchDevicePath "/dev/input/event*"

           Driver "libinput"

           Option "Tapping" "True"

           Option "PalmDetection" "True"

           Option "TappingDragLock" "True"

    EndSection

  • I have the same problem--did you fix it? Somewhere else I read that you're not supposed to have that libinput package, but there should be one with 'hwe' in the name that is made for your system. Still, I installed that to no avail. If you have any solutions, I'd like to hear it. edit: I found that it only happens with the menus integrated in the window decoration. After running gsettings set com.canonical.Unity integrated-menus false, you can simply tap-to-click on the menus. But I don't like the menus in the top bar (especially because it saves no vertical space at all). – bluppfisk Aug 2 '17 at 17:05

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.