I'm trying to install saws https://github.com/donnemartin/saws on ubuntu, installation using pip install saws seems to work, but when I type saws it says

No command 'saws' found, did you mean:

I've tried also with sudo and restarting terminal, any idea?

  • What is the output of pip install saws?
    – zondo
    Apr 5, 2017 at 2:57
  • Requirement already satisfied: saws in ./.local/lib/python2.7/site-packages amongs other lines with requirement already satisfied, the first time I ran it installed without problems
    – Arnold Roa
    Apr 5, 2017 at 3:06

1 Answer 1


That's installing in your ~/.local/bin directory, which probably isn't part of your PATH. One thing you could do is copy it to a directory that is in your PATH, such as /usr/local/bin. Another way would be to add .local/bin to your PATH:

$ export PATH=$PATH:~/.local/bin

You would need to put this in your .bashrc for it to execute every time you open your terminal.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.