5

I get

this message

every few minutes on Kubuntu (KDE), and the panels disappear.

It restarts itself automatically, so it's not a real problem, just an annoyance, but it is a big annoyance.

I've tried sudo apt install --reinstall plasmashell plasma-desktop, but that made no difference.

When I try a backtrace from the error message, it says it's unable to produce a useful backtrace.

6
  • How much RAM do you have?
    – Andrew Che
    Apr 5 '17 at 4:24
  • 4 gigs. I plan to upgrade when I have the means. Is that the problem?
    – Grund
    Apr 5 '17 at 5:09
  • I get the same issue constantly but my panels remain... Apr 5 '17 at 5:29
  • Look at this Apr 5 '17 at 5:41
  • Ubuntu version, KDE Version?
    – Bruni
    Apr 5 '17 at 9:10
6

Try installing the latest version of Plasma as a backport:

sudo apt-add-repository ppa:kubuntu-ppa/backports
sudo apt update && sudo apt full-upgrade -y
3
  • Has this helped? Jun 18 '19 at 18:07
  • 1
    @Supernormal This is how I solved the issue Jun 24 '19 at 19:24
  • Seems to have worked for me too! Aug 6 '19 at 6:58
1

First, if you have any non-standard plasma widgets, I would try to remove those.

Then, I would kill plasmashell process and then run it from the command line to see the full debug output.

to get a useful backtrace you need to install the *-dev related packages.

about widgets: potentially removing your whole panel, or widgets on your background and recreating a new panel if you want. is an option.

finally, you could inspecting your local plasma related config files.

$ find .config/ | grep plasma
.config/plasma-localerc
.config/plasmavaultrc
.config/plasma-org.kde.plasma.desktop-appletsrc
.config/plasmanotifyrc
.config/plasmarc
.config/plasmawindowedrc
.config/plasmawindowed-appletsrc
.config/plasmashellrc
.config/plasma-nm

you could back them up and move them away between restarts. I would start by .config/plasma-org.kde.plasma.desktop-appletsrc

hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.