I have tried most of the solutions I could find (came from here: USB stick read only when should be read/write), but to no avail.

The USB drive seems to be mounted in read-only on any operating system.. Could it be that the USB somehow turned on write protection on the hardware level? The last thing I was doing was copying some large video files on it, at which it suddenly stopped.

I successfully copied the video files on another USB drive, so I doubt that they caused this issue.

This is some info concerning the USB drive in question:

               description: Mass storage device
               product: Flash Disk
               vendor: USB
               physical id: 3
               bus info: usb@2:3
               logical name: scsi5
               version: 11.00
               serial: SCY0000000092741
               capabilities: usb-2.00 scsi emulated scsi-host
               configuration: driver=usb-storage maxpower=300mA speed=480Mbit/s
                  description: SCSI Disk
                  physical id: 0.0.0
                  bus info: scsi@5:0.0.0
                  logical name: /dev/sdb
                  size: 7800MiB (8178MB)
                  capabilities: partitioned partitioned:dos
                  configuration: logicalsectorsize=512 sectorsize=512 signature=00e47162
                     description: Windows FAT volume
                     vendor: MSDOS5.0
                     physical id: 1
                     bus info: scsi@5:0.0.0,1
                     logical name: /dev/sdb1
                     logical name: /media/egalea/FORENSICS
                     version: FAT32
                     serial: 0655-8d0c
                     size: 7797MiB
                     capacity: 7799MiB
                     capabilities: primary bootable fat initialized
                     configuration: FATs=2 filesystem=fat label=FORENSICS mount.fstype=vfat mount.options=ro,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro state=mounted

Here is the result of fsck /dev/sdb1

    fsck from util-linux 2.27.1
    fsck.fat 3.0.28 (2015-05-16)
    open: Read-only file system
  • It remounts read-only on error. Did you ever fsck the USB? – ubfan1 Apr 5 '17 at 4:04
  • Yes, I have checked it for errors and viruses and it has none. – mountaincloud Apr 5 '17 at 8:51
  • Given the information you have provided (including below comment of lots of r/w operations previously), and that all else seems to check out OK, we can likely presume this to be duplicate of the canonical question superuser.com/questions/1125282/… ; do not be put off by the mention of registry keys, it applies also here since it is likely a hardware problem. – taifwa Apr 6 '17 at 12:31
  • I have tried most solutions, including changing registry keys, using diskpart to clean / change to write mode, and unmounting and formatting on gparted, but none have succeeded. It is most probably a hardware problem and I have given up on it. I doubt there is any way to physically erase data is there? It is pretty much useless already. – mountaincloud Apr 6 '17 at 14:07

There are a lot of mount options there, of which (seen on last line):


where "ro" is "read-only"

You could try

mount -o remount,rw,uid=$UID /media/egalea/FORENSICS

And see if that helps.

  • I have tried remounting in rw but it says that it is write-protected. – mountaincloud Apr 5 '17 at 8:51
  • It would help then to paste us the actual output of fsck /dev/sdb1 ; can you also confirm there is no hardware toggle for write protection? Finally, what is the exact output of the remount command? – taifwa Apr 5 '17 at 9:50
  • I editted the post with the result of the fsck – mountaincloud Apr 6 '17 at 12:03

USB flash sticks do wear out. Symptoms usually of increasing errors, going read-only (because of uncorrected errors), and finally not even being recognized as a device when inserted. After heavy writing, whether many small files or a big one, the problem shows up suddenly. The smaller in size the USB stick, the hotter they become, and you can get sudden failures.

Don't trust the stick for anything important. Monitor your errors periodically. If errros show up again, try a reformat, but even that may kill the stick. If the failure becomes total (device not even seen by system when inserted), before discarding it, try to (gently) pull it apart -- some of them have a micro-SD card inside, which may be fine. Some stick failures are not of memory, but of the reading electronics, so if a micro SD card is present, check it out separately, it may still be good.

  • Well, I did do a lot of read/writes since I used it for an assignment and had to write / read 1,000,000+ txt files for a number of iterations. – mountaincloud Apr 6 '17 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.