2

enter image description here

I added /boot/efi/ubuntu/shimx64.efi to the database of accepted UEFI secure boot keys, but in still running into this when I try to boot Ubuntu.

When I add grubx64.efi to the database as well, Ubuntu loads just fine, although I thought shimx64.efi is the signed key not grubx64.

What is going on here and how can I fix this. I don't see why this is happening.

3

You will need to disable secure boot. This is how I did for my windows 10, hp laptop https://support.hp.com/nz-en/document/c04784866

It worked for me. After disabling secure boot. Restart your computer and keep on pressing ESC (or ant other key according to your laptop) until you get boot options then press F9 and it will allow you to choose boot to windows or linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.