2

I have installed wine and installed Adobe Digital Editions (ADE 4.5). When I started the icon ADE 4.5 nothing happened. Only this old version ADE 1.7 worked. But ADE 1.7 does not work with my ebook reader, kobo aura edition 2.

I have Googled for help with "Adobe Digital Editions installations under Linux" But all information I find is old.

When using winetricks, I get You are using a 64-bit WINEPREFIX and a lot that I didn't understand.

Might it be a 32-bit / 64-bit problem or a wrong window version under wine causing the newest ADE 4.5.4 not to work?


I tried what you suggested, but I get E: Paket winehq-devel could not be found. The same with winehq-stable

It was the same when changing to standard sources: http://packages.linuxmint.com http://archive.ubuntu.com/ubuntu I have Linux Mint 18.1 Serena

5
  • 2
    This sounds more like a WINE bug report than a problem with Ubuntu Apr 4 '17 at 15:16
  • 1
    Close voters. This question has been answered
    – Elder Geek
    Apr 4 '17 at 15:50
  • @ElderGeek seems to be off-topic though - see the last line.
    – Zanna
    Apr 5 '17 at 12:12
  • @Zanna, that edit wasn't by the OP and wasn't there when I answered. I rolled it back.
    – Elder Geek
    Apr 5 '17 at 12:27
  • @ElderGeek see the revisions and the deleted answer to see who made the edit and why :) Rolled again!
    – Zanna
    Apr 5 '17 at 12:30
3

According to the Wine Application Database Version 4.5 works well with the development version 2.5 of wine. Instruction on how to obtain and install this version is available here.

In a nutshell, the steps are as follows:

Preparation:

If you have previously installed a Wine package from another repository, please remove it and any packages that depend on it (e.g., wine-mono, wine-gecko, winetricks) before attempting to install the WineHQ packages, as they may cause dependency conflicts.

Your system will require Multiarch support

Add the repository:

wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/

Update packages and install:

sudo apt-get update && sudo apt-get install --install-recommends winehq-devel

You will notice some differences between the distro packages and the winehq builds. For more on this see the details.

According to winehq Ubuntu Multiarch support is still incomplete, so there may be further hoops to jump through that I am unable to test at present. The most current information I could find on this topic can be found here

Sources:

https://appdb.winehq.org/objectManager.php?sClass=version&iId=33276

https://wiki.winehq.org/Ubuntu

dpkg: How to remove a package and all other packages depend on it?

https://askubuntu.com/a/736651/225694

https://wiki.ubuntu.com/MultiarchSpec

2
  • Wait, we're already to WINE 2.5? v2.0 only got released a couple months ago! Apr 4 '17 at 16:13
  • @AndroidDev Time flies, doesn't it?
    – Elder Geek
    Apr 4 '17 at 17:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.