0

Yesterday I bought a Dell Inspiron N5010 which comes with following specs:

  • i5-640m
  • 6 GB RAM
  • Ati/Amd mobility radeon HD 5470

Because Ubuntu 16.04 doesn't have fglrx driver I installed 14.04 and machine is working fine.

The problem is the default driver for VGA is "Xserver Ati Driver" and I want to change it to "fglrx". Whenever I switched to Fglrx driver, computer won't boot up, stuck at black screen and doesn't let me go to Grub with left shift key or open tty with ctrl+alt+F1/F2 etc.

So far I tried:

  1. Enable fgrlx driver from additional sources and restart.
  2. Because it becomes that problem purged it(ubuntu made xserver default after that)
  3. Downloaded fgrlx driver from AMD support site and installed
  4. 2.step repeated so I purged again.

Currently I have xserver driver and it has problems with current Chrome/Chromium on 14.04 so I want to enable and use fglrx driver again.

0

Sadly I found the answer before people suggested.

After installing manual driver you need to write:

sudo amdconfig --initial -f

After writing this command reboot. My problem is solved by applying this step between manuel driver install and reboot process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.