4

I need to use pcf fonts but it seems that they are disabled now. I followed this thread without success. (both 70-yes-bitmaps.conf and -bitmaps)

The fonts are visible with xfontsel but the app can't see/use them. Any idea?

It used to work with Ubuntu 10.10 but I installed 11.10 now so I suspect GNOME 3 or Unity because there is no problem with KDE.

4

Try linking to 70-force-bitmaps instead. 70-yes-bitmaps doesn't seem to have anything in it. (This is taken from your link.) This worked for me on Ubuntu 12.04.


The process is like this (Added by a user on 14.04)

sudo ln -s /etc/fonts/conf.avail/70-force-bitmaps.conf /etc/fonts/conf.d/
sudo unlink /etc/fonts/conf.d/70-no-bitmaps.conf # For disabling no-bitmap setting

Then do this to update settings

sudo dpkg-reconfigure fontconfig
| improve this answer | |
1

As of Ubuntu 18.04, there seems to be no way to make all bitmap fonts available to font-config (therefore GUI applications), even one choose to use 70-force-bitmaps.conf. Take Lucida for example:

$ ls -l 70*
lrwxrwxrwx 1 root root 35 Sep 23 11:38 70-force-bitmaps.conf -> ../conf.avail/70-force-bitmaps.conf
$ xlsfonts | grep -ci lucida
1200
$ fc-cache | grep -ci lucida
0

Even enabling it by name wouldn't work

$ cat 50-enable-lucida.conf
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <selectfont>
    <acceptfont>
      <pattern>
        <patelt name="family"><string>lucida</string></patelt>
      </pattern>
    </acceptfont>
  </selectfont>
</fontconfig>
$ sudo dpkg-reconfigure fontconfig
$ fc-cache | grep -ci lucida
0

70-force-bitmpas.conf still makes a select few fonts work - they are fixed, unifont, wqy-bitmap, all of them are typically used in xterm, where fixed is the main font and the other two are backup fonts to cover CJK character set.

It seems there is a progressive trend towards discouraging the use of bitmap fonts except in the occasion it can't be forgone - terminal emulators.

| improve this answer | |
0

The fonts are visible with xfontsel but the app can't see/use them.

If you have enabled bitmap fonts in /etc/fonts/conf.d and updated font-cache with sudo fc-cache -fv but still not seeing the bitmap fonts in fc-list (therefore not seeing them in app's font selection), there is a possibility that the wrong font package was installed. For example, if you installed xfonts-100dpi-transcoded you will get a lot of PCF files and some of them are even big, but xfonts-100dpi is the package that provides fonts for font-config.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.