2

I have an Alienware 17 R4, and as the title says, 16.04.2 is not usable on my laptop, but 16.04.1 and 16.04 are.

When I say "not usable", I mean it will boot installer, and complete the install. However, upon clicking the Reboot button after the install finishes, the window closes and then it just hangs in the installer with no window.

If I force restart, it boots normaly. However, after entering my password and clicking Login, it hangs.

I have tried Ubuntu Mate and Ubuntu Gnome; both have the same issue. Linux mint, however, works fine.

So, does it matter if I use an older revision of 16.04? Alternatively, is there a way to fix the issues I'm experiencing with the newer revisions?

NB: I have a SkyLake CPU

  • Does 16.10 work? – You'reAGitForNotUsingGit Apr 3 '17 at 19:39
  • @AndroidDev let me try, gotta download it. however 17.04 of ubtuntu mate has hard issues. forgot to add that ubtuntu mate just locks up right at install starts – Urska Apr 3 '17 at 19:49
  • I guess it is because of your VGA or 3D card. because the NVIDIA 1070 is too new and bumblebee or nouveau doesn't fully compatible with your device. so please try to add nomodeset to your kernel parameters from grub and then install proprietary driver from software & update manually – Ali Razmdideh Apr 3 '17 at 20:04
  • @AndroidDev 16.10 has the same iusse – Urska Apr 3 '17 at 20:16
  • @ali dont really know how to do so... and if it was a GPU driver issues, wouldnt it be unable to boot install at all? also 16.04 and 16.04.1 work fine... same with linux mint ( current verison) run fine. even using nivda's drivers and out of box ones too – Urska Apr 3 '17 at 20:18
1

I have successfully installed ubuntu 16.10. Make sure you have the UEFI settings in place, turn off fast boot, secure login, etc..

Install ubuntu. (make sure you have a partition for uefi, aka 'esp' with > 100 mb)

at boot type 'e' to change grub. set nouveau.modeset=0 worked for me,

After Upgrade from 14.04 to 16.04 login screen runs in a loop while console login works

select the kernel recovery mode turn on networking

login as root

$echo "nameserver 8.8.8.8" > /run/resolvconf/resolv.conf

install the latest nvidia driver.

http://www.webupd8.org/2016/06/how-to-install-latest-nvidia-drivers-in.html

if you are in bootloop hell at this point, go back to your grubfile and remove anything you may have added like nomodeset or noveau.modset=0

bootup, and i was good to go. now i'm woking on wireless and ethernet... which works! but there are firmware issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.