2

Just upgraded to Xubuntu 16.04, and wanting to set up my VPN. I'm trying to save my password in the network manager, but it refuses to save. Anytime I go back to it it's gone.

I can also see that I have the field

[vpn-secrets]
password=my_secret_password

set in my connection details in /etc/NetworkManager/system-connections, but still nothing. Any other ideas I could try? Before my upgrade (actually a fresh install) this seemed to work perfectly fine in 14.04.

I've also issued the command

sudo service network-manager restart

but that didnt fix it either. I'll also note that my 'VPN Connections' -> 'Configure VPN' option is grayed out. I had to add VPN information through the 'Edit Connections' menu. Perhaps this clue is useful.

  • 1
    Does this answer help? – Owen Hines Apr 3 '17 at 13:50
  • Thanks for the suggestion. I switched password-flags to 0, did a 'sudo service network-manager restart', but it still doesn't seem to show that password when I open the GUI. – gammapoint Apr 3 '17 at 14:02
  • Sorry I couldn't help. I don't have any other suggestions for now, I just remembered seeing that answer a while ago. – Owen Hines Apr 3 '17 at 14:04
  • Please look at this post something about certificate being setup – George Udosen Apr 3 '17 at 14:19
  • Thank you for the suggestion, @George, but that user is apparently complaining about the save button being grayed out (i.e., unavailable) rather than my issue, which is that it will allegedly save but nothing will be there if I open up the GUI again. – gammapoint Apr 4 '17 at 12:13
7

I almost feel that this question should be deleted, since I was incorrect that I wasn't able to save VPN passwords in network-manager. In fact, what was happening was that the passwords were being saved (probably in my keyring), but that they just weren't being displayed back to me when I re-opened network manager. This makes sense from a security standpoint, but I just didn't realize that was the expected behavior. On top of this, I had an unrelated issue with actually connecting to the internet via my VPN, so that confounded this issue. Perhaps posting this will help someone else.

0

In Ubuntu 18.04 and previously in 16, you can allow saving of the VPN password by clicking the question mark

ubuntu vpn settings

This lists your options including:

  • Store the password only for this user
  • Store the password for all users
  • Ask for the password every time
  • The password is not required

If you choose one of the first two it should save the password for you.

The changes will also show in: /etc/NetworkManager/system-connections/{VPN Connection name} file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.