3

I try to run a programm on Ubuntu 16.10 x64, but I get the error:

Error while loading shared libraries: libminiupnpc.so.8: cannot open shared object file: No such file or directory

I tried to install the missing package by using this command:

sudo apt-get install libminiupnpc-dev

That gives me the following message:

libminiupnpc-dev is already the newest version (1.9.20140610-2ubuntu2).
The following packages were automatically installed and are no longer required:
  aptitude-common libcwidget3v5 libsigc++-2.0-0v5 libxapian22v5
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

So I guess its installed but in the wrong version. I tried to locate the file so I could just rename it or try to make a symbolic link or something, but could not find it on my system.

Any suggestions how to resolve this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.