4

After reinstalling Ubuntu 16.04 on my MacBook Air suspend doesn't work properly. I am able to suspend, and able to wake my laptop again, only the screen is entirely black.

No matter what I do, it stays black. I have tried entering TTYs, restarting lightdm over ssh, but nothing works. I know the computer is on, since I am able to access it over ssh.

Update: I have found that the problem only occurs when booting with the nomodeset option. Apparently this option lets the kernel handle the graphics, and as pointed out by @kukulo there is a bug in the kernel. I can boot without this option, but that makes my graphics and boot time significantly slower, so I am still looking for a solution to this problem. I tried upgrading the kernel to the latest stable release, but I am still seeing the problem.

1

This is a bug in the kernel, try to update to 4.4.8 kernel according this:

sudo apt-get -y install linux-image-4.8.0-58-generic

I have 16.04 on samsung n145 and after upgrading the kernel I can at least suspend from menu an wake up laptop via power button.

Note: The 4.4.0-112 kernel runs also fine on the n145, also the Meltdown patch is included. The included Atom processor is immune against Spectre attack.

  • I just upgraded to 4.10.8 which is the latest kernel, but I am still experiencing the issue. Do you think I should downgrade to 4.4.8? – tjespe Apr 2 '17 at 18:58
  • Can you suspend from menu? – kukulo Apr 3 '17 at 3:24
  • No, same result – tjespe Apr 3 '17 at 6:33
  • With the 4.4.8 I can suspend at least from menu, with closing lid I have the same problem as before. I had earlier 14.04 installed and suspend with closing lid worked. – kukulo Apr 3 '17 at 10:48
  • Are you booting with the nomodeset option? Just wondering how related our problems are before I try downgrading the kernel – tjespe Apr 3 '17 at 15:40

protected by Community Jul 31 '17 at 12:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.