2
  1. Laptop: Lenovo ThinkPad SL300 with integrated Syntek camera (17ef:480a)
  2. OS: Xubuntu 16.04.2 LTS, 4.8.0-45-generic 64 bit

Camera works in Windows 10 and according to archive posts it worked before with Linux, e.g. with Ubuntu 8.10.

Xubuntu detects my camera as USB2.0 UVC PC Camera. I tried Skype, Cheese and guvcview (results below) with the same effect: the camera LED switches ON but webcam window is black. Starting apps with LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so [app] doesn't change anything.

tom@ThinkPad-SL300:~$ guvcview -d /dev/video0
GUVCVIEW: version 2.0.2
V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
...
V4L2_CORE: Control 0x80000000 failed to query with error -1
buggy V4L2_CTRL_FLAG_NEXT_CTRL flag implementation (workaround enabled)
V4L2_CORE: (get control values) empty control list
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
...
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
...
V4L2_CORE: (VIDIOC_S_PARM) error: Input/output error
V4L2_CORE: Unable to set 1/24 fps
V4L2_CORE: Could not grab image (select timeout): Resource temporarily unavailable

Is this a bug or a "feature"?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.