2

I have Ubuntu 14.04 already installed but needed to install Ubuntu 16 on another partition. The installation went smoothly but when I boot now I don't get an option to boot Ubuntu 14 or Ubuntu 16, and my system always boots Ubuntu 14.

When I tried to find the reason behind this I found that the partition on which Ubuntu 16 is installed is not mounted when system start.

Even after editing fstab to mount the drive, GRUB is still not showing up

How can I make my system ask me OS to boot?

  • You don't see option for 16 but you do see the grub menu? – Sumeet Deshmukh Apr 2 '17 at 5:30
  • No I don't get grub menu too, system directly starts in ubuntu 14 – Niranjan Nimbalkar Apr 2 '17 at 5:32
  • That should give you the option to choose, comment if it's still not showing the option – Sumeet Deshmukh Apr 2 '17 at 5:37
  • Ok I am installing the grub-customizer and will update the result – Niranjan Nimbalkar Apr 2 '17 at 5:37
  • 1
    @Zanna, yes the partition was not mounted, but even after editing fstab there was no grub menu appearing. but Sumeet's solution did the trick and now the issue is solved :) – Niranjan Nimbalkar Apr 2 '17 at 5:49
3

Install Grub Customizer

To do that, Open terminal by pressing Ctrl+alt+T, and enter the following commands one by one

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

After installing it open it and enable the option Show grub menu on startup

  • Bull's eye, worked perfectly as expected, Many thanks Sumeet. – Niranjan Nimbalkar Apr 2 '17 at 5:47
  • You're always welcome – Sumeet Deshmukh Apr 2 '17 at 5:50

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.