0

i just want to set the maximum frequency of my cpu, it can go from 1.7GHz to 2.4GHz, i used cpufrequtils and tried "performance" and "userspace" but it didn't work. Here's is my cpufreq-info output:

It says "hardware limits: 768 MHz - 2.40 GHz" but then it says "current policy: frequency should be within 1.70 GHz and 1.70 GHz. The governor "userspace" may decide which speed to use within this range." so i don't know how to actually do it. I also found that maybe cpufrequtils will not work for my intel cpu using as default pstate

cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 768 MHz - 2.40 GHz
  available frequency steps: 2.40 GHz, 2.40 GHz, 2.30 GHz, 2.20 GHz, 2.00 GHz, 1.90 GHz, 1.70 GHz, 1.60 GHz, 1.50 GHz, 1.40 GHz, 1.30 GHz, 1.20 GHz, 1.10 GHz, 900 MHz, 800 MHz, 768 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1.70 GHz and 1.70 GHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 1.70 GHz.
  cpufreq stats: 2.40 GHz:0,00%, 2.40 GHz:0,00%, 2.30 GHz:0,00%, 2.20 GHz:0,00%, 2.00 GHz:0,00%, 1.90 GHz:0,00%, 1.70 GHz:31,70%, 1.60 GHz:0,02%, 1.50 GHz:0,00%, 1.40 GHz:0,00%, 1.30 GHz:0,00%, 1.20 GHz:0,00%, 1.10 GHz:0,00%, 900 MHz:0,00%, 800 MHz:0,00%, 768 MHz:68,28%  (7)
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 768 MHz - 2.40 GHz
  available frequency steps: 2.40 GHz, 2.40 GHz, 2.30 GHz, 2.20 GHz, 2.00 GHz, 1.90 GHz, 1.70 GHz, 1.60 GHz, 1.50 GHz, 1.40 GHz, 1.30 GHz, 1.20 GHz, 1.10 GHz, 900 MHz, 800 MHz, 768 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 768 MHz and 1.70 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.70 GHz.
  cpufreq stats: 2.40 GHz:0,00%, 2.40 GHz:0,00%, 2.30 GHz:0,00%, 2.20 GHz:0,00%, 2.00 GHz:0,00%, 1.90 GHz:0,00%, 1.70 GHz:99,98%, 1.60 GHz:0,02%, 1.50 GHz:0,00%, 1.40 GHz:0,00%, 1.30 GHz:0,00%, 1.20 GHz:0,00%, 1.10 GHz:0,00%, 900 MHz:0,00%, 800 MHz:0,00%, 768 MHz:0,00%  (3)
analyzing CPU 2:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 2
  CPUs which need to have their frequency coordinated by software: 2
  maximum transition latency: 10.0 us.
  hardware limits: 768 MHz - 2.40 GHz
  available frequency steps: 2.40 GHz, 2.40 GHz, 2.30 GHz, 2.20 GHz, 2.00 GHz, 1.90 GHz, 1.70 GHz, 1.60 GHz, 1.50 GHz, 1.40 GHz, 1.30 GHz, 1.20 GHz, 1.10 GHz, 900 MHz, 800 MHz, 768 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 768 MHz and 1.70 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.70 GHz.
  cpufreq stats: 2.40 GHz:0,00%, 2.40 GHz:0,00%, 2.30 GHz:0,00%, 2.20 GHz:0,00%, 2.00 GHz:0,00%, 1.90 GHz:0,00%, 1.70 GHz:99,98%, 1.60 GHz:0,02%, 1.50 GHz:0,00%, 1.40 GHz:0,00%, 1.30 GHz:0,00%, 1.20 GHz:0,00%, 1.10 GHz:0,00%, 900 MHz:0,00%, 800 MHz:0,00%, 768 MHz:0,00%  (3)
analyzing CPU 3:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 3
  CPUs which need to have their frequency coordinated by software: 3
  maximum transition latency: 10.0 us.
  hardware limits: 768 MHz - 2.40 GHz
  available frequency steps: 2.40 GHz, 2.40 GHz, 2.30 GHz, 2.20 GHz, 2.00 GHz, 1.90 GHz, 1.70 GHz, 1.60 GHz, 1.50 GHz, 1.40 GHz, 1.30 GHz, 1.20 GHz, 1.10 GHz, 900 MHz, 800 MHz, 768 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 768 MHz and 1.70 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.70 GHz.
  cpufreq stats: 2.40 GHz:0,00%, 2.40 GHz:0,00%, 2.30 GHz:0,00%, 2.20 GHz:0,00%, 2.00 GHz:0,00%, 1.90 GHz:0,00%, 1.70 GHz:99,98%, 1.60 GHz:0,02%, 1.50 GHz:0,00%, 1.40 GHz:0,00%, 1.30 GHz:0,00%, 1.20 GHz:0,00%, 1.10 GHz:0,00%, 900 MHz:0,00%, 800 MHz:0,00%, 768 MHz:0,00%  (3)

This is what i get when i use "grep . /sys/devices/system/cpu/cpu*/cpufreq/*"

/sys/devices/system/cpu/cpu0/cpufreq/affected_cpus:0
/sys/devices/system/cpu/cpu0/cpufreq/bios_limit:1700000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq:1700000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq:2401000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq:768000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_transition_latency:10000
/sys/devices/system/cpu/cpu0/cpufreq/freqdomain_cpus:0 1 2 3
/sys/devices/system/cpu/cpu0/cpufreq/related_cpus:0
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies:2401000 2400000 2300000 2200000 2000000 1900000 1700000 1600000 1500000 1400000 1300000 1200000 1100000 900000 800000 768000 
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors:conservative ondemand userspace powersave performance 
/sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq:1700000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver:acpi-cpufreq
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor:userspace
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq:1700000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq:1700000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed:1700000
/sys/devices/system/cpu/cpu1/cpufreq/affected_cpus:1
/sys/devices/system/cpu/cpu1/cpufreq/bios_limit:1700000
/sys/devices/system/cpu/cpu1/cpufreq/cpuinfo_cur_freq:1700000
/sys/devices/system/cpu/cpu1/cpufreq/cpuinfo_max_freq:2401000
/sys/devices/system/cpu/cpu1/cpufreq/cpuinfo_min_freq:768000
/sys/devices/system/cpu/cpu1/cpufreq/cpuinfo_transition_latency:10000
/sys/devices/system/cpu/cpu1/cpufreq/freqdomain_cpus:0 1 2 3
/sys/devices/system/cpu/cpu1/cpufreq/related_cpus:1
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_frequencies:2401000 2400000 2300000 2200000 2000000 1900000 1700000 1600000 1500000 1400000 1300000 1200000 1100000 900000 800000 768000 
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors:conservative ondemand userspace powersave performance 
/sys/devices/system/cpu/cpu1/cpufreq/scaling_cur_freq:1700000
/sys/devices/system/cpu/cpu1/cpufreq/scaling_driver:acpi-cpufreq
/sys/devices/system/cpu/cpu1/cpufreq/scaling_governor:performance
/sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq:1700000
/sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq:768000
/sys/devices/system/cpu/cpu1/cpufreq/scaling_setspeed:<unsupported>
/sys/devices/system/cpu/cpu2/cpufreq/affected_cpus:2
/sys/devices/system/cpu/cpu2/cpufreq/bios_limit:1700000
/sys/devices/system/cpu/cpu2/cpufreq/cpuinfo_cur_freq:1700000
/sys/devices/system/cpu/cpu2/cpufreq/cpuinfo_max_freq:2401000
/sys/devices/system/cpu/cpu2/cpufreq/cpuinfo_min_freq:768000
/sys/devices/system/cpu/cpu2/cpufreq/cpuinfo_transition_latency:10000
/sys/devices/system/cpu/cpu2/cpufreq/freqdomain_cpus:0 1 2 3
/sys/devices/system/cpu/cpu2/cpufreq/related_cpus:2
/sys/devices/system/cpu/cpu2/cpufreq/scaling_available_frequencies:2401000 2400000 2300000 2200000 2000000 1900000 1700000 1600000 1500000 1400000 1300000 1200000 1100000 900000 800000 768000 
/sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors:conservative ondemand userspace powersave performance 
/sys/devices/system/cpu/cpu2/cpufreq/scaling_cur_freq:1700000
/sys/devices/system/cpu/cpu2/cpufreq/scaling_driver:acpi-cpufreq
/sys/devices/system/cpu/cpu2/cpufreq/scaling_governor:performance
/sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq:1700000
/sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq:768000
/sys/devices/system/cpu/cpu2/cpufreq/scaling_setspeed:<unsupported>
/sys/devices/system/cpu/cpu3/cpufreq/affected_cpus:3
/sys/devices/system/cpu/cpu3/cpufreq/bios_limit:1700000
/sys/devices/system/cpu/cpu3/cpufreq/cpuinfo_cur_freq:1700000
/sys/devices/system/cpu/cpu3/cpufreq/cpuinfo_max_freq:2401000
/sys/devices/system/cpu/cpu3/cpufreq/cpuinfo_min_freq:768000
/sys/devices/system/cpu/cpu3/cpufreq/cpuinfo_transition_latency:10000
/sys/devices/system/cpu/cpu3/cpufreq/freqdomain_cpus:0 1 2 3
/sys/devices/system/cpu/cpu3/cpufreq/related_cpus:3
/sys/devices/system/cpu/cpu3/cpufreq/scaling_available_frequencies:2401000 2400000 2300000 2200000 2000000 1900000 1700000 1600000 1500000 1400000 1300000 1200000 1100000 900000 800000 768000 
/sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors:conservative ondemand userspace powersave performance 
/sys/devices/system/cpu/cpu3/cpufreq/scaling_cur_freq:1700000
/sys/devices/system/cpu/cpu3/cpufreq/scaling_driver:acpi-cpufreq
/sys/devices/system/cpu/cpu3/cpufreq/scaling_governor:performance
/sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq:1700000
/sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq:768000
/sys/devices/system/cpu/cpu3/cpufreq/scaling_setspeed:<unsupported>
  • Put CPU 0 to the performance governor also. Determine what is limiting the maximum CPU frequency to 1.7 GHz. What do you get for grep . /sys/devices/system/cpu/cpu*/cpufreq/* ? Edit the results into your question. – Doug Smythies Apr 1 '17 at 20:46
  • O.K. so your BIOS is setting the upper CPU frequency limit. Perhaps for a thermal reason or, depending on your computer brand, power supply issues. – Doug Smythies Apr 1 '17 at 22:46
  • Ok, thanks, but i have another partition with windows and it can go to 2,4GHz, so my next question is: can i just modify it manually? – Sebastian Tare B. Apr 1 '17 at 23:51
  • 1
    What computer model and manufacturer do you have? What you should do if figure out why BIOS is setting a limit. While I highly recommend against it, you could set ignore_ppc to 1. If you do it manually, echo 1 | sudo tee /sys/module/processor/parameters/ignore_ppc you will still have to manually set the max frequencies. The other way is to do it on the command line in grub, GRUB_CMDLINE_LINUX_DEFAULT="processor.ignore_ppc=1" – Doug Smythies Apr 2 '17 at 19:12
  • Ok, thanks, i put the ignore_ppc and modified the max freq values and then i was able to change my current freq. – Sebastian Tare B. Apr 3 '17 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.