I'm running Ubuntu 10.10 32-bit. Kernel v2.6.35-30generic. Skype v2.2.0.35-0maverick1.

After connecting the Microsoft LifeCam NX-6000 webcam, the microphone works fine, but the video refuses to work on Skype, even though Skype recognises the webcam. On Cheese, it does not even recognise the webcam, and reports "No device found".

I have tried both 32-bit solutions on this page: http://community.linuxmint.com/tutorial/view/219. Initially, the light on the webcam only blinked once after plugging in and then remained off. However, after the above fix, the light remains on, though the video does not work.

How do I get this to work? Are there any outputs that I need to provide?

  • Does starting skype with this command LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype work? – Rinzwind Dec 23 '11 at 6:48
  • Tried. Doesn't fix the problem. – Satchit Bhogle Dec 23 '11 at 7:27
  • After consulting askubuntu.com/questions/3557/… I was able to figure out that the webcam was not supported by the 2.6.35-x kernel. Upgrading to 2.6.36 did the trick. – Satchit Bhogle Dec 23 '11 at 9:28
  • Can you please add that as an answer and accept it (when the system allows you). Then others will benifit from your searching ;) Good job solving it! – Rinzwind Dec 23 '11 at 10:02
  • Somebody please.Scarcely can I use skype on my computer. – el10780 Jan 26 '12 at 22:26

After consulting How can I get my Microsoft Lifecam VX-1000 webcam microphone to work?, I was able to figure out that the webcam was not supported by the 2.6.35-x kernel. Upgrading to 2.6.36 did the trick.


Just recovering from the same problem. It used to work until about one week ago, so I suspected an ubuntu update was the culprit. However after reading that someone had the problem that activating his webcam disabled his wifi, and finding that after trying to activate my webcam, I lost my umts connection, I suspected something else might be going on.

Indeed I had moved the umts usb device to one of the usb ports on the backside of my computer last week. So I moved the umts device back to the frontside again - and it works like a charm!

cam & umts on the backside: cam not working, loose umts connection upon trying to activate cam

cam on backside, umts on frontside: everything works as expected. (Tested using cheese and skype)

I really have no clue what's going on here, but it seems to have something to do with different usb devices not playing along together. I'd recommend unplugging all other usb devices (might be necessary to do so prior to rebooting) and see if your webcam works. Then try to find out which one is causing the trouble.

  • Thanks for your answer.Well,I tried this but unfortunately nothing happened.What is culprit?Is it possible to remove it or return to a version of it which will make my webcam work? – el10780 Feb 2 '12 at 21:45
  • With culprit I meant the thing that is causing the trouble. In my case, it seems it's an incompability of webcam and umts modem. In your case, I don't know. When I google for the error message you posted, I get some results for users experiencing similar problems with other webcam models. Seems some got it working by downloading and modifying uvc driver source and compiling the module. Perhaps you will find something useful searching for "uvcvideo: Failed to query" on google... – Axel Feb 3 '12 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.