7

Got a new battery for my laptop, and the laptop with the new battery shuts down a few seconds after unplugging the charger. This is not the ubuntu shut down, but a hard one, like what would have happened to a desktop if it was unplugged from power.

Additional facts:

  • The bios recognizes the new battery, and can run its calibrate on it, to drain it. Draining takes about 2 hours, with fan and screen running, so the battery is not outright disfunctional.

  • It seems that shut down happens on SSD access. I can boot, only on the battery, a clean Ubuntu 16.04 from usb in "live" mode, and it would run until I'd click on the SSD folder to see what's inside. Then it would shut down.

  • The battery supplier replaced the battery two times, all three batteries have the same problem. No problem with the original battery.

The question is - can this be an Ubuntu problem, perhaps the OS somehow not getting along with the new battery's controller?

Ubuntu: 14.04, Laptop: Samsung np900x.

Update: There is a BIOS testing utility, as described here. It reports many ACPI related errors - log. Not yet sure what to do about them.

  • 1
    I'm not sure how helpful it will be, but could you post the output of cat /var/log/syslog at paste.ubuntu.com ? – Android Dev Apr 1 '17 at 10:47
  • link Removed some lines about [UFW BLOCK]. This is system running with charger. – komark Apr 1 '17 at 10:59
  • Do you have any information on the drive? I have some steps to follow. – user595510 Apr 1 '17 at 11:01
  • @komark please re-post that after you unplug. – user595510 Apr 1 '17 at 11:02
  • could try the same thing with the boot from usb only on battery. If I do manage to open the terminal, would the syslog be still at '/var/log/syslog'? – komark Apr 1 '17 at 11:08
2

I think you may have a system with a buggy or out of spec ACPI firmware. Ideally you should be able to disable ACPI in the BIOS as shown below:

IMG:

Another option would be to use the acpi=off kernel parameter. You can test this by editing the vmlinuz line at boot and adding the acpi=off parameter. to make it permanent, edit /etc/default/grub with your favorite text editor; find the line:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 

and add the acpi=off parameter to the space separated list of parameters between the quotes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.