4

I'm trying to make a Ubuntu live USB, but I have run into some problems:

  1. Used LiveUSB install on my Lubuntu laptop. Breaks USB drive until reformatted, does not boot.
  2. Used Startup Disk Creator on Lubuntu. Makes bootable drive, but not persistant storage
  3. Used UNetBootin on Lubuntu, puts Ubuntu on USB stick but does not make it bootable
  4. Tried to use Universal USB Installer with WINE, but it didn't work. The first time it could only see the floppy disk drive not the USB, the next time it threw an NSIS error.
  5. Tried to use Universal USB Installer on Windows, but it needed admin permissions

I have a laptop with Lubuntu installed* (that I have the sudo password for), a Windows 8 desktop without administrator permissions and a 32GB sandisk USB stick. Is there anything else I can do to get it to work?

*IBM T-42 Thinkpad with 1GB ram and an intel Centrio mobile processor that I had to force PAE to get Lubuntu to install if it is relevant.

As requested: sudo lsblk -f

NAME   FSTYPE  LABEL                    MOUNTPOINT
sdb    iso9660 Ubuntu 16.04.2 LTS amd64 2017-02-15-21-44-13-00               
├─sdb2 vfat    Ubuntu 16.04.2 LTS amd64 E561-C446                            
└─sdb1 iso9660 Ubuntu 16.04.2 LTS amd64 2017-02-15-21-44-13-00               
sr0                                                                   
fd0                                                                   
sda                                                                   
├─sda5 swap                             d571c534-8cb6-4e61-889c-6289f5a33421 [SWAP]
├─sda1 ntfs                             F8E0DED8E0DE9BE6                     
└─sda6 ext4                             b14a062d-7884-494c-99fe-ddfe5bd5f4b4 /


sudo lsblk -m

NAME    SIZE OWNER GROUP MODE
sdb    28.7G root  disk  brw-rw----
├─sdb2  2.4M root  disk  brw-rw----
└─sdb1  1.5G root  disk  brw-rw----
sr0    1024M root  cdrom brw-rw----
fd0       4K root  disk  brw-rw----
sda    37.3G root  disk  brw-rw----
├─sda5 1022M root  disk  brw-rw----
├─sda1   14G root  disk  brw-rw----
└─sda6 22.3G root  disk  brw-rw----
  • 2
    The reason that all the programs need admin is because they have to do a low level write the boot sector of the device in question - even if you wanted to create the bootable stick using dd in the terminal, you'd still have to run it as root. – Android Dev Apr 1 '17 at 10:44
  • I'm not surprised that they do - however the fact remains that I can't use them on Windows if they need it! Thanks for the explanation of why they do. – J.Smith Apr 1 '17 at 11:21
  • I can confirm that you have found a bug. I think it depends on some 'junk output' that confuses the listing of available drives, when there is a floppy drive. I'm testing a bugfix now. – sudodus Apr 2 '17 at 7:58
2

I have an IBM T-42 Thinkpad too, and Lubuntu 32-bit works with the boot option forcepae.

I suggest that you install mkusb according to the following links,

help.ubuntu.com/community/mkusb

help.ubuntu.com/community/mkusb/persistent

Then, with mkusb installed, you can create a persistent live drive with all current versions of Ubuntu (also 64-bit versions for newer computers).

See also the following links for more details,

how-do-i-make-a-persistent-live-usb-of-ubuntu-16-04

unable-to-boot-ubuntu-live-usb-flash-drive-with-casper-rw-persistent-partition


Edit: After a debugging dialogue, a bug was found and squashed. The problem was some confusing data due to a floppy drive (a bug that only affects very old computers).

A new version can be installed via the following commands

sudo add-apt-repository ppa:mkusb/ppa
sudo apt-get update
sudo apt-get dist-upgrade

The current update (2017-04-03) installs mkusb version 12.0.9

  • Comments are not for extended discussion; this conversation has been moved to chat. – Thomas Ward Apr 3 '17 at 14:59
  • @ThomasWard, Is there a way that I can create/convert to a chat myself? So far I have been prompted to it (a few cases). In this case the OP was prompted and tried, but did not manage to open the chat. I have searched for a button to start a chat, but not found it. – sudodus Apr 3 '17 at 16:45
  • No, it's a moderator only feature, but it will also automatically show up if you have a very long string saying something along the lines of "Comments are not meant for extended, perhaps consider moving it to chat" with a link you can click. Mods can force the entire chat thread to a chatroom, standard users need to be prompted with the prompt to 'create the chatroom' yourself. (That's a question for Meta next time, by the way) – Thomas Ward Apr 3 '17 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.