I'm trying to install bang and olufsen drivers, or HP hd audio driver, as only 2 of the 4 speakers work and the 2 amps don't work in ubuntu

lspci -v | grep -i audio
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
    Subsystem: Hewlett-Packard Company Broadwell-U Audio Controller
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
    Subsystem: Hewlett-Packard Company Wildcat Point-LP High Definition Audio Controller

The volume is terrible. Is there any way to fix this?

The speakers work perfectly on the pre-installed Windows 8.

  • There are no other drivers.
    – user589808
    Apr 1 '17 at 8:21
  • Can you post amixer -c 0 and amixer -c 1 in your question?
    – Tom Yan
    Aug 13 '17 at 23:42
  • 1
    @MathCubes Your link is about headphones and this question is about speakers. Most reports are headphones work great and top two speakers (powered by separate amplifier) work in Windows but not Linux. Aug 13 '17 at 23:44

Two years later it is possible!

There is a new answer with a comment confirming it works. The link is included so people are apprised of updates to this issue.

Original answer

This is no longer true but left her for posterity purposes.

It doesn't seem possible

I looked on HP website and found this:

The so-called "HP Expert" there said it's like trying to put a jet engine in a car and make it fly like an AirBus A380. So not very promising. He did reference another question here in Ask Ubuntu:

...however that has no answers either.

Do a little more digging

I did a little more digging and found this bug report:

There are 91 comments posted from November 29, 2016 up to yesterday (August 12, 2017). There are various band-aid approaches people have tried. I suggest you subscribe to the bug report and keep abreast of bug fixes / work arounds.

Like your system there are two front speakers powered from motherboard and two back speakers powered by separate amplifier.

The most successful band-aid to date requires installing a windows update and rebooting into Linux. This "tricks" the amplifier to being powered on. After rebooting into Linux poking in some register configuration values is required. You can read all about it in the 91 comments but I just wanted to summarize it for you.

Hopefully someone will reverse-engineer the Windows driver for Bang & Olufsen and create one for Linux. It doesn't appear HP is willing to do it.


I purchased a late 2017 Spectre X360, model 13-ae013dx. I was able to solve this bug consistently using HDAJackRetask under Antergos by performing the following:

  • Override pin 0x14 and set it to Internal Speaker (LFE). I believe this enables the amplifier that drives the top speakers. Setting it to something other than just "Internal Speaker" is important, so that pulseaudio does not try to redirect sound to that channel.

  • Override pin 0x1e and set them to "Internal Speaker".

Hit Apply Now, and voila you have sound out of all four speakers.

Screenshot below:


I'm currently running Kernel 4.20.10-arch1-1-ARCH, and I have tried absolutely everything on this thread to no avail. Hope this helps!

  • I have a late 2017 Spectre 15 inch and I think this worked very well for me. Your PASTEBOARD IMAGE was very helpful! I have to mention that the "Apply Now" failed with error that it was busy; however, applying to boot override and rebooting worked!
    – armc
    Jan 6 at 20:28
  • @armc Thank you for confirming this answer from a very old problem. I've added it to my answer so people know to come here instead. Jan 7 at 0:32

Based on @robertjjoynt answer from https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1648183/comments/17

and Mayank Sharma has written a detailed answer on How to install Bang and Olufsen Audio drivers for HP laptop?

follow the instructions there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.