0

I am trying to install etcd 2.2 on Ubuntu 14.04.

This command aptitude install etcd results in a variety of complex messages.

This command apt-get install etcd results in this message:

E: Package 'etcd' has no installation candidate

I downloaded a .tar.gz file for etcd 2.2. I expanded it to install it from this stand alone package. I then entered the new directory that was created. When I run ./etcd I get this message and the installation hangs:

2017-03-31 20:39:48.384030 I | raft: raft.node: ce2a822cea30bfca elected leader ce2a822cea30bfca at term 4
2017-03-31 20:39:48.384708 I | etcdserver: published {Name:default ClientURLs:[http://localhost:2379 http://localhost:4001]} to cluster 7e27652122e8b2ae

What should I do?

I expected ./etcd to progress and allow the etcdctl commands to work. There is no evidence etcd is installed.

0

Looking at the logs it seems ok. Do you mean after printing the mentioned lines command prompt returns? Run below command from the same directory and see if you are able to communicate.

./etcdctl set mykey "this is awesome" 
./etcdctl get mykey

I used below steps for installation and it worked fine for me:

curl -L  https://github.com/coreos/etcd/releases/download/v2.1.0-rc.0/etcd-v2.1.0-rc.0-linux-amd64.tar.gz -o etcd-v2.1.0-rc.0-linux-amd64.tar.gz
tar xzvf etcd-v2.1.0-rc.0-linux-amd64.tar.gz
cd etcd-v2.1.0-rc.0-linux-amd64
./etcd
| improve this answer | |
  • I get "No such file or directory." etcd has not been installed. How do I install it? The installation hangs. Nothing I try ever works. – Alex111 Apr 3 '17 at 15:24
  • Added instruction for installation that I used. – Vivek Apr 7 '17 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.