13

So I am on my college network which requires me to sign in to the browser before I start using the internet. I do so succesfully but on a clean install of Ubuntu, when I try to do sudo apt update, I get the following output:

$ sudo apt update
Get:1 http://in.archive.ubuntu.com/ubuntu xenial InRelease [2,847 B]
Err:1 http://in.archive.ubuntu.com/ubuntu xenial InRelease                    
Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [2,854 B]    
Err:2 http://security.ubuntu.com/ubuntu xenial-security InRelease             
...
Get:3 http://in.archive.ubuntu.com/ubuntu xenial-updates InRelease [2,855 B]   
Err:3 http://in.archive.ubuntu.com/ubuntu xenial-updates InRelease
...
Get:4 http://in.archive.ubuntu.com/ubuntu xenial-backports InRelease [2,857 B]
Err:4 http://in.archive.ubuntu.com/ubuntu xenial-backports InRelease
Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Fetched 11.4 kB in 0s (18.3 kB/s)
Reading package lists... Done
E: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/xenial/InRelease  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
...
E: Some index files failed to download. They have been ignored, or old ones used instead.

But when I do wget http://in.archive.ubuntu.com/ubuntu/dists/xenial/InRelease, I get this output success:

2017-04-01 05:34:57  http://in.archive.ubuntu.com/ubuntu/dists/xenial/InRelease
Resolving in.archive.ubuntu.com (in.archive.ubuntu.com)... 91.189.88.162, 91.189.88.149, 91.189.88.152, ...
Connecting to in.archive.ubuntu.com (in.archive.ubuntu.com)|91.189.88.162|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 246846 (241K)
Saving to: ‘InRelease.3’

InRelease.3         100%[===================>] 241.06K   110KB/s    in 2.2s    

2017-04-01 05:35:00 (110 KB/s) - ‘InRelease.3’ saved [246846/246846]

Clearly I have internet access from my browser and on wget but when I do sudo apt (or apt-get) update I get this error.

PS: This question is not similar to other threads as their solutions do not seem to work on mine

As I have found out, this problem is happening only to me, not others on the college network. Despite setting up the network according to instructions, this still happens. Any more help would be appreciated

EDIT: So as it turns out, 50% of us in the college are facing this issue, while 50% aren't despite having no issues with the hardware and sudo apt update before the last week. Thanks to @David Foerster for helping me throughout all this time.

As it stands, the issue has been raised to our college's networking department :)

  • What's the output of wget -qO- http://in.archive.ubuntu.com/ubuntu/dists/xenial/InRelease | head? – David Foerster Apr 1 '17 at 9:11
  • Did you configure any HTTP proxy server on your system or for Apt specifically? How is the system connected to the internet? Usually this type of error stems from faulty proxy configuration or misbehaving proxy servers. – David Foerster Apr 1 '17 at 11:44
  • The problem as it stands seem to be Apt specific only, that too on the College WiFi. This is because Wget also works seamlessly – Sparker0i Apr 2 '17 at 15:48
  • For the third time now, could you please change the Ubuntu repository mirror and try to reproduce the issue? If this only happens in your college network I advise you to contact the local network administrators for support because they know the local network infrastructure and HTTP proxy servers. Thanks. – David Foerster Apr 2 '17 at 20:11
  • 2
    To close voters: The issue was related to an upstream network problem according to OP's answer. – David Foerster Jul 11 '17 at 16:13
8

I had the same issue. It turns out that apt-get uses /etc/apt/apt.conf for the proxy settings (my browser settings are already set). Making apt.conf match my browser proxy settings solved the problem.

/etc/apt$ cat apt.conf

Acquire::http::proxy "http://<proxy>";
Acquire::https::proxy "https://<proxy>";
Acquire::ftp::proxy "ftp://<proxy>";
Acquire::socks::proxy "socks:<proxy>";
  • Note: you have to create this file in 16.04 (it doesn't previously exist). – nobar May 31 '17 at 21:55
  • It is clearly a bug that this is required. A major bug for those affected. – nobar May 31 '17 at 21:58
  • You probably only need the http row. And don't forget the port: http://<name>:<port>. – nobar May 31 '17 at 23:00
  • Yep! First thing I had to do with my WSL of Ubuntu was running echo Acquire::http::proxy \"http://$proxy:$port\";" | sudo tee -a /etc/apt/apt.conf and echo Acquire::https::proxy \"https://$proxy:$port\";" | sudo tee -a /etc/apt/apt.conf; then I was golden for using apt-get – kayleeFrye_onDeck Dec 8 '17 at 0:32
  • @brian What should I write instead of <proxy> ? – TSR Feb 3 '18 at 12:40
4

Turns out it was a problem in our college's network backend. Issues still exist with it, other WiFi networks work fine.

  • This does not do any help to anyone. What was the problem with your college network? – Musa Nov 21 '18 at 4:28
  • Well, can't say what but they have blocked any request that comes from apt, because when I open the repository URL, it works fine – Sparker0i Nov 22 '18 at 19:07
0

when you having such issued, first make sure the DNS can resolve the links, which l think is the problem.

sudo vim /etc/resolv.conf

make sure you use google dns :

nameserver 8.8.8.8

as the first name server to check. restart the networking.service and you will be good to go

  • 1
    The name resolution is fine according to the question (compare the listed IP addresses with the output of host in.archive.ubuntu.com 8.8.8.8) but the HTTP proxy settings were not. -1 – David Foerster Mar 7 '18 at 13:55

protected by Community Jun 21 '18 at 23:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.