6

I'm having a problem with the BCM43142A0 Bluetooth module. I've already tried this solution: Bluetooth Broadcom 43142 isn't working.

BT hardware such as headphones can now be connected but keep losing connection (audio stops and resumes out of joint with video). Als othe system keeps freezing. Last entries /var/log/syslog are bluetooth-related almost every time.

I have a usb-dongle which should be working but need to disable the internal one (hoping that this will end the crashing).

lsusb gives:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 048d:8386 Integrated Technology Express, Inc. 
Bus 001 Device 003: ID 03eb:8c1d Atmel Corp. 
Bus 001 Device 006: ID 105b:e065 Foxconn International, Inc. BCM43142A0 Bluetooth module
Bus 001 Device 004: ID 5986:0535 Acer, Inc  
Bus 001 Device 007: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I would like to disable the one from foxconn while leaving the other one (from cambridge silicon radio) active.

I think this isn't possible by editing /etc/modprope.d/blacklist because this would deactivate bluetooth altogether.

1 Answer 1

8

You can create a udev rule to disable the internal bluetooth

sudo -H gedit /etc/udev/rules.d/81-bluetooth-hci.rules

Paste the following in

SUBSYSTEM=="usb", ATTRS{idVendor}=="105b", ATTRS{idProduct}=="e065", ATTR{authorized}="0"

Save, exit text editor and reboot

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.