3

I am running Ubuntu 16.04 on Fujitsu UH552. Every thing has been working fine until I connected Bluetooth wireless headphone. My machine has qualcomm atheros ar9462 (wifi + bluetooth) module.

Problem: If I use both Bluetooth headphone and WiFi at the same time they interfere, WiFi slows down and audio on headphone has glitches. Any suggestion how to solve this issue?

Note:Upon googling I found this solution

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi bt_coex_active=N"

but this is not working for me.

  • 1
    That command is for Intel adapters only. – Pilot6 Mar 31 '17 at 14:51
4

Since yours is an Atheros wireless device and not an Intel, it is not surprising that a driver parameter for an Intel is not working. Let's try a better option:

sudo -i
rm /etc/modprobe.d/iwlwifi-opt.conf
echo "options ath9k btcoex_enable=1"  >  /etc/modprobe.d/ath9k.conf
exit

Reboot and let us hear your report.

  • Works well for me so far. Reboot wasn't necessary, I did modprobe -r ath9k; sleep 5; modproble ath9k But it's a fair suggestion. – Sergiy Kolodyazhnyy Jul 19 '19 at 16:00
  • Unfortunately this solution is for the ath9k driver only. There's no btcoex_enable option for the ath10k driver, at least at the moment. – Yury Kirienko Jul 28 '20 at 16:24
  • @YuryKirienko Almost every wireless driver solution is only valid for the specific driver mentioned. You can find the available parameters for your device with: modinfo ath10k_pci | grep parm If you need additional help, please ask your own new question. – chili555 Jul 29 '20 at 13:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.