1

After reading around on the internet and even trying the ubuntu forums, I've decided to come here for help. Here's some information that may be useful:

My partitions are as follows (as seen from the Ubuntu installation):

/dev/sda ATA ST31000524AS (1.0 TB)
/dev/sda1 ntfs 104MB 29MB used Windows 7 (loader)
/dev/sda2 ntfs 912682 unknown used Windows 7 (loader)
/dev/sda4 ext4 / 79224MB Ubuntu
/dev/sda3 swap 8191MB unknown used

/dev/sdb  ATA SAMSUNG HD 103SI (1.0TB)
/dev/sdb1 ntfs 1000202MB unknown used Windows 10 (loader)

Previously, this machine had Windows 7 installed on it. At that time, an external hard drive of mine had some of its hardware broken, so I pulled the drive out and stuck it in my machine as an internal drive. I think that is what /dev/sdb is. Shortly after that, I upgraded from Windows 7 to Windows 10, and successfully had Ubuntu 15.10 running alongside it.

Recently, I have tried to install Ubuntu 16.10 via USB. The USB was in UEFI mode, although my BIOS is set to Legacy (so I can boot into Windows 10). After I did that, I was being sent to the grub rescue screen. An ls at the grub rescue screen yields:

(hd0) (hd0,msdos1) (hd1) (hd1,mosdos4) (hd1,msdos3) (hd1,msdos2) (hd1,msdos1) (hd2) (hd2,msdos1).

ls (hd1,msdos4)
(hd1,msdos4): Filesystem is ext2

I have tried the instructions here: [redacted due to lack of reputation/can't post more than 2 links]

  1. set prefix=(hdX,Y)/boot/grub Use the values determined earlier. Example: If the Ubuntu system is on sda5, >enter: set prefix=(hd0,5)/boot/grub 2.* set root=(hdX,Y) Example: set root=(hd0,5)
  2. insmod normal Attempt to load the normal module.
  3. normal Activate the normal module. If successful, the GRUB 2 menu may appear.
  4. set (Optional) Review the current settings.
  5. ls /boot (Optional) Check for a vmlinuz and a initrd.img entry.
  6. insmod linux An error message usually means the path is incorrect. 8.* linux /vmlinuz root=/dev/sdXY ro Selects the latest kernel. Example: linux /vmlinuz root=/dev/sda5 ro
  7. initrd /initrd.img Selects the latest initrd image.
  8. boot

At some point, I also tried some e2fsck commands, https://pastebin.com/SM2fMXHr

I have just now tried to run a boot repair, and here are the results: http://paste.ubuntu.com/24282296/

After all that, my question is:

What should I do to be able to boot into Ubuntu and Windows 10?

  • It doesn't look like you've done an EFI-mode installation; it looks like it's BIOS-mode, but with GRUB (somewhat strangely) installed to /dev/sdb. It looks like Ubuntu was meant to be installed to /dev/sda4, but that partition is showing bad filesystem damage. I recommend you try re-installing Ubuntu, but you may want to read my page on the CSM first, to help you control the boot mode. Also, be sure to create a fresh filesystem on ("reformat") /dev/sda4 when you install. – Rod Smith Mar 31 '17 at 17:32
0

You can't. The only time I have seen machines with both you have to choose at boot. On a cold start what F-Keys are offered? Most have a bios and a boot choice. Mine is F-12. Have a live CD? Boot that and choose test Ubuntu. The next restart do it again and choose HD. then the boot screen will show the choices to boot Ubuntu or a Windows 7 or 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.