2

Totally apologize for not meeting all the standards here. Been using Ubuntu since Nov 2015 and performed two upgrades I'm still a rookie and have not found the exact problem in any Ubuntu searches. Here's the 3 broken dependencies listed in the Synaptic Package Manager under broken Dependencies:

  1. CUPS 2.1.3-4unbuntu0.2 2.1.3-4ubuntu0.2 Common UNIX Printing System(tm)-PPD/driver, support web interface

  2. CUPS-core-drivers 2.1.3-4unbuntu0.2 2.1.3-4ubuntu0.2 Common UNIX Printing System(tm)-PPD-less printing

  3. CUPS-Daemon 2.1.3-4 2.1.3 Common UNIX Printing System(tm)-Daemon

This PC is only used at home as a stand-alone and only connected to the IT. I can still print with no problem, however, since this occurred last week after performing an update. The only problem this causes the inability to perform any updates, which is a serious problem.

I will provide any info you need, but will need step by step help.

2

This is a bug in a recent CUPS update: cups : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.2 is to be installed

Solution given in comment 14 is: sudo apt-get install libcups2=2.1.3-4 cups libcupscgi1=2.1.3-4 libcupsimage2=2.1.3-4 libcupsmime1=2.1.3-4 libcupsppdc1=2.1.3-4 cups-core-drivers cups-daemon ghostscript cups-client=2.1.3-4 cups-ppdc cups-filters printer-driver-gutenprint cups-filters

| improve this answer | |
  • Results: ron@ron-Aspire-X3910:~$ apt-get -f install E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root? ron@ron-Aspire-X3910:~$ – Ronald Railing Mar 31 '17 at 12:11
  • Not much info there due to space. I copied terminal cmds and results, but to long to post. Tried to unlock file and then tried kill cmd and reboot per article ubuntuforums.org/showthread.php?t=1853026 – Ronald Railing Mar 31 '17 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.