2

I have been following this guide to install an Ubuntu 16.04.2 LTS (Desktop) system:

https://github.com/zfsonlinux/zfs/wiki/Ubuntu-16.04-Root-on-ZFS

I have completed everything up to step 6.4 and just rebooted the server. All steps prior to that were completed successfully. I am running a system with an EFI BIOS and it is configured to boot of EFI first and fall back to legacy. I have followed only the "EFI" related steps in the installation guide as it suggests following only one or the other.

I have rebooted, and the grub boot loader comes up fine, the default option boots after 5 seconds, and the kernel comes up - so initially all is well.

However about 4 seconds in, I see the message:

Begin: Running /scripts/local-block ... done.

repeated numerous times.

Then the system fails with:

ALERT: ZFS=rpool/ROOT/ubuntu does not exist. Dropping to shell!

I have a BusyBox shell but not sure where I've gone wrong. Can anyone please advise? I've seen many people have followed this guide successfully so I'm not clear where I've gone wrong.

Thanks in advance!

  • This is almost certainly not your problem, but if you intend to boot in EFI mode, setting your firmware to enable the BIOS/CSM/legacy boot option, even as a fallback, is harmless at best and can lead to problems at worst. See this page of mine for details on this subject. As I said, though, this is most likely not the cause of your problem; I mention it because it could become a problem in the future or be a problem for somebody else. – Rod Smith Mar 30 '17 at 14:22
0

I ran into this same issue. The fix for me involved adding to the linux line of my grub boot entry. In my case, it was missing the boot=zfs entry.

(note: this is for debian, so adjust to your kernel etc)

linux    /ROOT/debian@/boot/vmlinuz-4.9.0.3-amd64 root=ZFS=rpool/ROOT/debian ro boot=zfs $bootfs quiet

which once you get where you can get into your system, you can edit /etc/default/grub and add to GRUB_CMDLINE_LINUX_DEFAULT="quiet" to make it

GRUB_CMDLINE_LINUX_DEFAULT="boot=zfs $bootfs quiet"

That should get you booted, and you may want to write it down, as future upgrades may break it again :)

Happy ZFSing!

  • 1
    Hello, I'm having this same issue and after entering the boot params in grub and hitting F10, it dropped to: /init .: line 259: can't open '/scripts/zfs' - after which it seems to just hang. Do you have any idea what that might be? I will try the process again to see if I copied it wrong but I was fairly painstaking when I did it so not holding my breath... – AveryFreeman Jul 15 '18 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.