6

I'm on Ubuntu MATE 16.04.1 and I changed graphic card to GeForce 8600GT and now I can't enter LUKS password on boot after installing NVIDIA propriatary drivers (I tried 304.135 and 340.102). Keyboard does not work there, I only have such screen and I can't enter anything:

enter image description here

To boot my OS I need to go through recovery mode and it boots fine, but I would like to fix it by perhaps changing that passphrase screen to text-mode. I know that there should be such mode for this as I have it on another machine with another GeForce, only thing that it's on 14.04 and it switched to text-mode automatically right after installing NVIDIA driver.

How do I do this on 16.04?

PS. I've tried THIS solution (both wxh and text) and it does not work for me - not any passphrase screen appears...

4
  • Did you try installing nvidia-375 from apt? – Shreyash S Sarnayak Mar 30 '17 at 13:40
  • Same issue, but can't even boot to recovery mode on 375 - getting FAILED on some Braille Device Support... – GreggD Mar 30 '17 at 15:28
  • 2
    What happens if you remove the boot options quiet splash? You can do so quickly if you select a Grub entry, enter editing mode with the keyboard shortcut "C", edit the line starting with linux accordingly and press Ctrl+X to execute the listed commands. – David Foerster Apr 2 '17 at 23:43
  • 1
    Oh! So simple! Needed to remove it from /etc/default/grub as Ctrl+X does not work here... and it looks like recovery mode, only don't need to go through GRUB and recovery mode, so it's good enough for me :) If you want, you can make an answer out of this, I'll give you those points. – GreggD Apr 3 '17 at 12:25
5
+50

I have enabled this on my Ubuntu 16.04 server that has XFCE installed.

Edit /etc/default/grub with your text editor of choice, and remove the option quiet splash, and then if this does not work I would suggest also adding GRUB_GFXPAYLOAD_LINUX=text on a new line in /etc/default/grub. Remember, after you make a change to the grub config file, you should always run

sudo update-grub

to apply the changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.