0

I have x1 yoga OLED and screen is always at max brightness. From what I've read since it's OLED the usual dimming doesn't work but this command is needed:

xrandr --output eDP1 --brightness .5 

warning: output eDP1 not found;

ignoring xrandr: Need crtc to set gamma on

0

I know is an old post but I was having the same issue with a Gigabyte OLED laptop.

Your command is almost good except for the eDP1. If you run xrandr without arguments, you should find a line with something similar to eDP. In my case was eDP-1-1. Try running your command with this new name. It worked for me.

0

OLED brightness on linux has been hit & miss for the past 4 years or so (since OLED came to laptops).

There are numerous ways to set OLED brightness manually, here's the ones I found more useful:

xrandr --output $oled_screen --brightness $percent

$percent is a value between 0.0 and 1.0, $oled_screen is your oled panel screen name. To get a list of attached screens run xrandr without any arguments.

redshift -m randr:screen=$oled_screen -P -O $temperature -b $percent

This is an example of how to manually set brightness and night light filter. $oled_screen is the same as above, $temperature is the color temperature of the display (6500 for normal, unaltered colors, 3500 is a usual value for a night filter), $percent is a value between 0.1 and 1.0 and it specifies the brightness of the display. It acts the same as when using xrandr, but redshift prevents you from setting values lower than 0.1 while xrandr allows even values of 0.0 (pitch black)

redshift -P -O $temperature -b $percent

Same as above, but changes will be applied to all screens. Useful if you don't want to look for screen names when you only have 1 screen anyway.

Anyway, I doubt you are just looking for "how to set brightness using a command" and would appreciate a solution that "just works" on your shiny amazing OLED display. This repsository is probably the solution you are looking for. It "just works" in most cases, and with little tweaking you can get the brightness control similar to how it works out of the box on LCD displays. There is also a comprehensive documentation in README.md

-1

Try this:

xrandr --verbose |egrep '(Bright|Gamma)'

then

xrandr --output VGA1 --brightness .75

Alternatively

echo "7" > brightness where 7 is the brightness value obtained from

# cat brightness

7
  • doesnt work either user@computer:~$ xrandr --verbose |egrep '(Bright|Gamma)' Gamma: 1.0:1.0:1.0 Brightness: 1.0 user@computer:~$ xrandr --output VGA1 --brightness .75 warning: output VGA1 not found; ignoring xrandr: Need crtc to set gamma on. user@computer:~$ echo "7" > brightness where 7 is the brightness value obtained from # cat brightness user@computer:~$ echo "7" > brightness where 7 is the brightness value obtained from # cat brightness user@computer:~$ xrandr --verbose |egrep '(Bright|Gamma)' Gamma: 1.0:1.0:1.0 Brightness: 1.0 user@computer:~$ – user240891 Apr 1 '17 at 10:25
  • I fixed the command , also try checking here: askubuntu.com/q/57236/653540 – xavier_fakerat Apr 1 '17 at 11:13
  • The command seems the same? However, still doesn't work :( – user240891 Apr 2 '17 at 20:13
  • By the way which graphics card do you use? – xavier_fakerat Apr 2 '17 at 20:22
  • Intel® HD Graphics 520 (Skylake GT2) – user240891 Apr 5 '17 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.