1

Spacevim doesn't have colors in Terminator (Ubuntu 16.10), but it does have colors in other terminals apps, such as Gnome Terminal, or XTerm:

enter image description here

One at the top is Terminator, and Gnome Terminal on the bottom.

They're both using ZSH with ohmyzsh addons. I've added export TERM="xterm-256color" to my .zshrc and it does report the same amount of colors as the other terminal apps:

$ tput colors
256

I've tried using the system color schemes as well using custom, changing the colorscheme in Spacevim - but nothing happened. Any help would be appreciated. Thanks!

Update: update to Ubuntu 17.04 solved the problem

1

I am author of SpaceVim, by default SpaceVim use true colors, you can add let g:spacevim_enable_guicolors = 0 to ~/.SpaceVim.d/init.vim. If it still does not work, please open issue in

https://github.com/SpaceVim/SpaceVim

or send email to me.

Shidong Wang wsdjeg@outlook.com

| improve this answer | |
  • Hi @Wang Shidong - I really appreciate your eyes on this. I've kept digging and it seems to me that it's Terminator that doesn't have working true color support. If I type printf "\x1b[38;2;255;100;0mTRUECOLOR\x1b[0m\n" in Terminator it's grey, however all other terminal emulator shows orange. I've read that true color came to Terminator after version 1.90, however I upgraded it to 1.91 and still having the same issue. Until I'm convinced it's not a Terminator issue I won't report it on your github. Thanks again! – itarato Mar 30 '17 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.