4

Some time back I tried to install a package which was successful. But after that if I tried to install any new package I am getting an error.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 cpp-4.8-arm-linux-gnueabihf : Depends: gcc-4.8-arm-linux-gnueabihf-base (= 4.8.4-2ubuntu1~14.04.1cross0.11.2) but 4.8.5-4ubuntu1cross2 is to be installed
 lib64gcc-4.7-dev:i386 : Depends: gcc-4.7-base:i386 (= 4.7.4-3ubuntu12) but it is not going to be installed
                         Depends: lib64gcc1:i386 (>= 1:4.7.4-3ubuntu12) but it is not going to be installed
                         Depends: libx32gcc1:i386 (>= 1:4.7.4-3ubuntu12) but it is not going to be installed
                         Depends: lib64gomp1:i386 (>= 4.7.4-3ubuntu12) but it is not going to be installed
                         Depends: libx32gomp1:i386 (>= 4.7.4-3ubuntu12) but it is not going to be installed
                         Depends: lib64itm1:i386 (>= 4.7.4-3ubuntu12) but it is not going to be installed
                         Depends: libx32itm1:i386 (>= 4.7.4-3ubuntu12) but it is not going to be installed
                         Depends: lib64quadmath0:i386 (>= 4.7.4-3ubuntu12) but it is not going to be installed
                         Depends: libx32quadmath0:i386 (>= 4.7.4-3ubuntu12) but it is not going to be installed
                         Recommends: libc6-dev:i386 (>= 2.13-0ubuntu6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

After which if i run sudo apt-get -f install I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  cpp-4.8-arm-linux-gnueabihf gcc-4.8-arm-linux-gnueabihf
Suggested packages:
  gcc-4.8-locales gcc-4.8-multilib-arm-linux-gnueabihf gcc-4.8-doc libgcc1-dbg-armhf-cross libgomp1-dbg-armhf-cross libitm1-dbg-armhf-cross
  libatomic1-dbg-armhf-cross libasan0-dbg-armhf-cross libtsan0-dbg-armhf-cross libquadmath0-dbg-armhf-cross
The following packages will be upgraded:
  cpp-4.8-arm-linux-gnueabihf gcc-4.8-arm-linux-gnueabihf
2 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
633 not fully installed or removed.
Need to get 0 B/10.2 MB of archives.
After this operation, 967 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up libegl1-mesa:amd64 (11.2.0-1ubuntu2.2) ...
update-alternatives: unknown argument `--force'

Usage: update-alternatives --install    
       update-alternatives --remove  
       update-alternatives --help
 is the link pointing to the provided path (ie. /usr/bin/foo).
 is the name in /usr/lib/opkg/alternatives/alternatives (ie. foo)
 is the name referred to (ie. /usr/bin/foo-extra-spiffy)
 is an integer; options with higher numbers are chosen.

dpkg: error processing package libegl1-mesa:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of libwayland-egl1-mesa:amd64:
 libwayland-egl1-mesa:amd64 depends on libegl1-mesa (= 11.2.0-1ubuntu2.2); however:
  Package libegl1-mesa:amd64 is not configured yet.

dpkg: error processing package libwayland-egl1-mesa:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk-3-0:amd64:
 libgtk-3-0:amd64 depends on libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1; however:
  Package libwayland-egl1-mesa:amd64 is not configured yet.
  Package libwayland-egl1 is not installed.
  Package libwayland-egl1-mesa:amd64 which provides libwayland-egl1 is not configured yet.

dpkg: error processing package libgtk-3-0:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgcr-ui-3-1:amd64:
 libgcr-ui-3-1:amd64 depends on libgtk-3-0 (>= 3.12.0); however:
  Package libgtk-3-0:amd64 is not configured yet.

dpkg: error processing No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                                 No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                     No apport report written because MaxReports is reached already
                                                                                                                                                   No apport report written because MaxReports is reached already
                                                           No apport report written because MaxReports is reached already
                                                                                                                         No apport report written because MaxReports is reached already

No apport report written because MaxReports is reached already
                                                                                               package libgcr-ui-3-1:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcr:
 gcr depends on libgcr-ui-3-1 (>= 3.8.0); however:
  Package libgcr-ui-3-1:amd64 is not configured yet.
 gcr depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0:amd64 is not configured yet.

dpkg: error processing package gcr (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pinentry-gnome3:
 pinentry-gnome3 depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0:amd64 is not configured yet.
 pinentry-gnome3 depends on gcr; however:
  Package gcr is not configured yet.

dpkg: error processing package pinentry-gnome3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnupg-agent:
 gnupg-agent depends on pinentry-curses | pinentry; however:
  Package pinentry-curses is not installed.
  Package pinentry is not installed.
  Package pinentry-gnome3 which provides pinentry is not configured yet.

dpkg: error processing package gnupg-agent (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnupg2:
 gnupg2 depends on gnupg-agent (= 2.1.11-6ubuntu2); however:
  Package gnupg-agent is not configured yet.

dpkg: error processing package gnupg2 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Errors were encountered while processing:
 libegl1-mesa:amd64
 libwayland-egl1-mesa:amd64
 libgtk-3-0:amd64
 libgcr-ui-3-1:amd64
 gcr
 pinentry-gnome3
 gnupg-agent
 gnupg2
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anyways if try sudo apt-get update I dont see any error.

I tried to do even "dist upgrade" following is the error:

sudo apt-get dist-upgrade -y


    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    cpp-4.8-arm-linux-gnueabihf : Depends: gcc-4.8-arm-linux-gnueabihf-base  (=.8.4-2ubuntu1~14.04.1cross0.11.2) but 4.8.5-4ubuntu1cross2 is installed
    E: Unmet dependencies. Try using -f.

Someone please help me in solving this issue as its been causing problem for me.

Also I have read other posts but none helped me in fixing my issue.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.