7

I'm running a dual monitor setup in Ubuntu 16.04.2. When I activate unity expo it shows the desktop in all monitors, as illustrated below. buggy unity expo

Is it possible to make it show only the desktops on the current monitor (similarly to KDE)?

1
2
+250

I've noticed the same issue before, and have spent a long time trying to find a solution.

As I said, I have spent many a long hour studying it, and the only answer I can post, I'm afraid, is no, there is no way to do that with the Expo plugin. It has to be controlled by compiz, and the settings are unfortunately extremely limited. I searched around to see if there would be some way to change configurations, but it looks to me like short of editing the source code and recompiling, it is impossible.

The only workaround I found personally was instead of using the Expo plugin to use the Desktop Cube and Rotate Cube plugins, setting Multi-Output Mode to Multiple Cubes and unfolding the cube instead of opening the Expo. I don't like it as well, and it just shows a black or transparent spot where the other screen should be, but that's the best I've found.

0

Actually now this works fine now if you change the Multi Output Mode in Appearance to "One Big Wall" instead of "One Wall per output" which is the default, but the Windows will still move from one monitor to another as this is how the plugin works, it zooms out the viewports.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.