0

I have been trying for the past few days to install 'amdgpu-pro' on my PC but I keep getting missing firmware warnings and when I reboot my PC is running in low graphics mode.

I have a Radeon rx480. I have already tried looking on many different websites for a solution but many don't work or I don't understand.

I have done the normal cd then the folder, the I did

./amdgpu-pro-install -y. 

I got this missing firmware error:

W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_01.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_14.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver8_7.bin for module i915
Processing triggers for libc-bin (2.23-0ubuntu5) ...

Then when I reboot I get told I'm running in low graphics mode

kernel 4.8.0-36-generic

I have just uninstalled the driver so i can reboot my pc for tomorrow but I cannot find a solution. Thanks I am a student so i might be at school so i cant reply

  • Please edit your question and tell us exactly what you've tried and exactly what error you receive. – terdon Mar 29 '17 at 18:54
  • Please provide commands you have run and errors witnessed. – Andrew Crouthamel Mar 29 '17 at 18:54
  • Which kernel version are you using? Run uname -r to see. I think you might need the newer kernel and xorg from the HWE stack to get RX 480 working properly. – dobey Mar 29 '17 at 19:34
  • I think it is 4.8 because when it was building the amdgpu-pro it said 4.8._ generic but i cannot check right now. It is the one straight from the Ubuntu website – HappyHook Mar 29 '17 at 19:52
  • this is the kernel 4.8.0-36-generic – HappyHook Mar 30 '17 at 16:37
0

I solved my amdgpu-pro-17.30-465504 installation problem by following Mark Maurer's advise Troubles installing AMD drivers and ensure that I had "HWE - hardware enablement" installed. So I followed the instructions on this link https://wiki.ubuntu.com/Kernel/LTSEnablementStack and then reinstalled the amdgpu-pro drivers successfully.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.