0

I have a new Epson ET-2650 printer, which is connected to a Windows machine via USB. Works fine on Windows 7. I'm trying to print to this printer from a Ubuntu machine via a Samba connection. Unfortunately, the list of Epson printers on Ubuntu doesn't include any of the ET-series printers. (These are the new "ink tank" machines; the printer costs more but the ink is much cheaper).

I've tried setting the make and model to "Generic PostScript Printer Foomatic/Postscript (recommended)". Printing the test page results in printing the Postscript source as text, with the comment "If you can read this, you are using the wrong driver for your printer".

I tried looking on the Epson installer CD-ROM for a PPD file, but didn't find one.

No PPD file for this printer here: http://www.openprinting.org/driver/Postscript-Epson/

Any ideas?

Ubuntu 14.04 LTS x64.

  • If you just want a PPD file, follow @hamiheim 's link, type in your model, choose the Linux driver, and download the .tar.gz version. Then extract the desired PPD from the ppd folder in the .tar.gz file. – Nick Weinberg Mar 30 '17 at 6:29
1

Try downloading and installing the driver from the Epson Download Center.

  • Installing the entire Epson package worked. The PPD file alone did not; printing a test page produced no errors, but nothing was printed or queued. I didn't realize you needed the whole driver set to print to a Samba printer; I thought the machine with the printer did more of the device-specific work. – John Nagle Mar 30 '17 at 7:13
  • Not usually, samba shared printers is just a way of connecting to the printer itself, the actual spooling and conversion occur on the device initiating the print request. Think about when you connect to a shared printer on Windows, it still installs the driver for it, it's just usually done in the background do to the fact that it can use the same driver as the samba 'server' so to speak. – Gansheim Mar 30 '17 at 12:51
  • 1
    Just a little update, the 17.04 release of Ubuntu is supposed to support driverless printing. – Gansheim Apr 5 '17 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.