0

I'm trying to install Wine in Ubuntu 14.04, but I have some unmet dependencies and I have no idea how to fix them. I tried to install them manually, but things got worse and worse.

Results of running sudo apt-get install wine:

Reading package list....Done
Building Dependency tree
Reading state information...Done 
You may want to run 'apt-get -f install' to fix:
The following packages have unmet dependencies:
 libatk1.0-0:i386 : Depends: libc6:i386 (>= 2.2) but it is not going to be installed
 libclutter-1.0-0 : Breaks: libclutter-1.0-0:i386 (!= 1.16.4-0ubuntu2) but 1.10.0-0ubuntu1 it is going to be installed
 libclutter-1.0-0:i386 : Depends: libc6:i386 (>= 2.7) but it is not going to be installed
                         Depends: libcairo-gobject2:i386 (>= 1.10.0) but it is not going to be installed
                         Depends: libcairo2:i386 (>= 1.10) but it is not going to be installed
                         Depends: libcogl-pango0:i386 (>= 1.7.4) but it is not installable
                         Depends: libcogl9:i386 (>= 1.9.8) but it is not installable
                         Depends: libfontconfig1:i386 (>= 2.8.0) but it is not going to be installed
                         Depends: libgtk-3-0:i386 (>= 3.0.0) but it is not going to be installed
                         Depends: libjson-glib-1.0-0:i386 (>= 0.12.0) but it is not going to be installed
                         Depends: libpango1.0-0:i386 (>= 1.29.4) but it is not going to be installed
                         Depends: libx11-6:i386 (>= 2:1.2.99.901) but it is not going to be installed
                         Depends: libxcomposite1:i386 (>= 1:0.3-1) but it is not going to be installed
                         Depends: libxdamage1:i386 (>= 1:1.1) but it is not going to be installed
                         Depends: libxi6:i386 (>= 2:1.2.99.4) but it is not going to be installed
                         Breaks: libclutter-1.0-0 (!= 1.10.0-0ubuntu1) but 1.16.4-0ubuntu2 it is going to be installed
 libcogl15 : Breaks: libclutter-1.0-0:i386 (= 2.17) but it is not going to be installed
                     Depends: libffi6:i386 (>= 3.0.4) but it is not going to be installed
                     Depends: libpcre3:i386 but it is not going to be installed
                     Depends: libselinux1:i386 (>= 1.32) but it is not going to be installed
                     Depends: zlib1g:i386 (>= 1:1.2.2) but it is not going to be installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.40.2-0ubuntu1) but 2.40.0-2 is going to be installed
 wine : Depends: wine1.6
E: Unmet dependencies. Run 'apt-get -f install' without packages (or specify a solution).

I already tried:

sudo apt-get update
sudo apt-get install -f

Output:

nelson@nelson-hp:~$ sudo apt-get -f install
Reading package list....Done
Building Dependency tree
Reading state information...Done 
Correcting Dependencies.... failure
The following packages have unmet dependencies:
 libatk1.0-0:i386 : Depends: libc6:i386 (>= 2.2) but it is not installed
 libclutter-1.0-0 : Breaks: libclutter-1.0-0:i386 (!= 1.16.4-0ubuntu2) but 1.10.0-0ubuntu1 is installed
 libclutter-1.0-0:i386 : Depends: libc6:i386 (>= 2.7) but it is not installed
                         Depends: libcairo-gobject2:i386 (>= 1.10.0) but it is not installed
                         Depends: libcairo2:i386 (>= 1.10) but it is not installed
                         Depends: libcogl-pango0:i386 (>= 1.7.4) pero no es instalable
                         Depends: libcogl9:i386 (>= 1.9.8) pero no es instalable
                         Depends: libfontconfig1:i386 (>= 2.8.0) but it is not installed
                         Depends: libgtk-3-0:i386 (>= 3.0.0) but it is not installed
                         Depends: libjson-glib-1.0-0:i386 (>= 0.12.0) but it is not installed
                         Depends: libpango1.0-0:i386 (>= 1.29.4) but it is not installed
                         Depends: libx11-6:i386 (>= 2:1.2.99.901) but it is not installed
                         Depends: libxcomposite1:i386 (>= 1:0.3-1) but it is not installed
                         Depends: libxdamage1:i386 (>= 1:1.1) but it is not installed
                         Depends: libxi6:i386 (>= 2:1.2.99.4) but it is not installed
                         Breaks: libclutter-1.0-0 (!= 1.10.0-0ubuntu1) pero 1.16.4-0ubuntu2 está instalado
 libcogl15 : Breaks: libclutter-1.0-0:i386 (< 1.15) but 1.10.0-0ubuntu1 is installed
 libglib2.0-0:i386 : Depends: libc6:i386 (>= 2.17) but it is not installed
                     Depends: libffi6:i386 (>= 3.0.4) but it is not installed
                     Depends: libpcre3:i386 but it is not installed
                     Depends: libselinux1:i386 (>= 1.32) but it is not installed
                     Depends: zlib1g:i386 (>= 1:1.2.2) but it is not installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.40.2-0ubuntu1) but 2.40.0-2 is installed
E: Error, pkgProblemResolver::Unable to correct problems, this may have been caused by held packages.
E: Can't resolve the dependencies

I ran:

~$ sudo apt-cache policy libclutter-1.0-0:i386

Output:

libclutter-1.0-0:i386:
  Instalados: 1.10.0-0ubuntu1
  Candidato:  1.16.4-0ubuntu2
  Tabla de versión:
     1.16.4-0ubuntu2 0
        500 http://ar.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
 *** 1.10.0-0ubuntu1 0
        100 /var/lib/dpkg/status
  • apt-get update && apt-get install -f ; es duplicacion de askubuntu.com/questions/263378/… – taifwa Mar 29 '17 at 12:29
  • I already tested those commands. I will edit the question to mention that. – user3781074 Mar 29 '17 at 12:34
  • It looks like your version of libclutter is from 12.04... Pleqse provide the output of apt-cache policy libclutter-1.0-0. – fkraiem Mar 29 '17 at 13:03
  • @fkraiem I edited the question with the output. Thanks. – user3781074 Mar 29 '17 at 14:47
  • Sorry, that should have been libclutter-1.0-0:i386. – fkraiem Mar 29 '17 at 16:48
0

first you should install synaptic

sudo apt-get install synaptic

and then install cups from synaptic (by checking cups in synaptic) it will take care of dependency.

  • After running the command, it outputs the same as if it were "wine" package, poiting out each dependency... – user3781074 Mar 29 '17 at 14:45
  • you have to install wine package through synaptic tool not using terminal – sandip Apr 6 '17 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.