I have been running Ubuntu for a couple of months on this machine now, and all of a sudden the CPU's frequency is refusing to go any higher than 0.8GHz (20% of maximum) despite it running fine at 3.8-4.0GHz with the CPU temperature normal before.

This initially started after running Portal 2 through Steam, and I was able to correct the issue by changing my scaling_governor from 'powersave' to 'performance', however while I was actually in game the CPU would still cap at 0.8GHz around 95% of the time and occasionally spike momentarily to a maximum of around 2.0GHz.

To try and rectify this I looked at turning up my fan speed using lm-sensors and fancontrol. However after using pwmconfig, even after detecting multiple pwm controllers and found a correlation between one of them and my CPU's fan, my clock speed seems to be permanently capped at 0.8GHz, even after multiple reboots.

I've been using 'sensors' to check my fan speed and core temps, and while changing the pwm value does affect the RPM output in sensors (about 980RPM@150 and 2000RPM@255) I can not see or hear a noticeable difference in speed on the physical fan.

I tried changing the BIOS settings for the fans too, from Normal to Full Speed, and again no noticeable change in speed from the fan, however my clock speed worked for a little while like this at 3.8GHz again, but I tried running a few things to test it out and although my computer was faster, my core temp was rising way too fast and the fan clearly wasn't adjusting accordingly.

Any information about how to control fans and clock speeds from Ubuntu would be useful, I have seen similar issues around online, but none of the recommended solutions work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.